Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a weird situation with my Windows Vista X64 that doesn't always happen.

Sometime, when I'm booting, it freeze on the splash where the line's going right to left, the only thing that work is this crazy line. Nothing load, HardDrive doesn't load anything. If I do reset, it could work, but It might not and just do it all over again the same freaking loading splash.

Trying to boot to safe mode in these situation show me that windows looks to hang on crcdisk.sys file.

I've made many research on the web, many people looks to have this problem, not hardware related, but it seems that there's no magic solution to it except formatting but I want to avoid it, I can't spend days to reinstall all my stuff, I need my PC to work on many projects.

My PC worked just great the last 6 months, until this problem came out of no where two weeks ago. I didn't made any change on my machine either Software of Hardware since at least a month so It is not something I installed that cause this problem.

My windows is also fully up-to-date.

Thanks to everyone who'll try to help me.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

If you don't want to pay for spinrite you could try using chkdsk. Open a command window and at the prompt type: CHKDSK /R and press enter. It will probably ask to schedule a check at the next boot, (because the drive is in use), so press Y to agree.

If Windows will not load you will have to get a command prompt by booting from a regular Vista or Windows 7 Install disk

After chkdsk is done and it will still not load Windows, run a System File checker offline

There could also be an infection in Windows causing this, scan for infections using an AV boot CD or usb key.

share|improve this answer

Finaly vista just died by itself, I've just reinstall it and all is good up to now.

I flushed my raid array to be able to test individuals disk with WD tools and all is good, nothing wrong. So I rebuild the array and reinstall windows.

share|improve this answer

Spinrite might be able to help you out. Expensive but a brilliant tool to have.

share|improve this answer
    
I didn't loose anything, It's just something that block the boot sometime. Right now I'm on my PC and he's just working fine, but tomorrow vista could do it again, I never know. –  Marc-Andre R. Jul 17 '09 at 11:24
    
Spinrite has two levels. One level is for recovery and the other is for maintenance. There's a lot of Spinrite stories where people just run it and just having it look at the harddrive has helped –  Stephen Jul 17 '09 at 11:45
    
Sounds like a good time to take a backup of anything important on your computer onto a DVD or something –  David Hayes Jul 17 '09 at 21:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.