Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

What I want to do: Connect to the internet through my wifi router, via some other router that the room I rent provides.

What I have: 1 ethernet cable that comes into my apartment.

If I plug the ethernet cable into my computer it will work fine. I'm guess DHCP gives me my ip address and viola, 192.168.1.1 is my gateway (and I can see some router admin page that I have no control over or ownership of). Howver, if I plug this same ethernet cable into my otherwise working wifi router (have done this kind of setup before in the past) it fails to connect to the internet. I am using dd-wrt and it is set to Gateway mode and to use DHCP as the connection type.

I noticed that when my router is plugged in, it does not have a gateway ip set (perhaps because it is the gateway) for what it's worth.

edit: This is in Thailand. I suspect the LAN cable goes directly to the WAN and not through a modem. Not sure.

share|improve this question
    
If the initial router doesn't allow you to bridge, you won't be able to do this. Have you set up your router as an "extender"? –  Raystafarian Dec 24 '13 at 12:10
    
I have tried setting my router connect type to both gateway and router... no luck. I am trying to get my wifi router working over the single LAN cable provided... However one thought has occured to me... would it be possible to plug the provided LAN ethernet cable into the regular LAN slot and then point my windows network connection's "gateway IP" to the LAN IP of the router? –  Zombies Dec 24 '13 at 12:20
    
depends on the architecture of the network that exists. Worth a try. –  Raystafarian Dec 24 '13 at 12:43
2  
Does your WiFi router also use 192.168.1.0/24 as its internal network? There's no reason you can't chain NATs like that, but you have to keep the various internal network spaces from stepping on each others' toes. –  Bandrami Dec 24 '13 at 17:14
    
@Bandami I think so, what should I change it to since the parent most router is using 192.168.1.0/24 ? –  Zombies Dec 25 '13 at 0:29

1 Answer 1

up vote 3 down vote accepted

It happens often that people enable MAC filtering, in a misguided attempt at controlling access. The fact that your router does not receive an IP address seems to suggest as much.

This is a misguided attempt because it is easily thwarted,as I now show you. Your pc is obviously allowed to connect via ethernet, so first thing determine the MAC address of your ethernet card (you can easily Google that).

Then open the GUI of your DD-WRT router, Setup -> Mac Address Clone -> Enable, and fill in the relevant info. Save configuration, reboot, you might be good to go.

Edit:

Another possible cause of malfunction is if both routers are using a subnet 192.168.1.0/24, which would make it impossible, for router 2, to understand whether any given address lies on the LAN or on the WAN side. Try changing the subnet on the LAN side of router 2.

share|improve this answer
    
My router receives an IP address. It was 192.168.1.14 but in its configuration, the gateway was not set which I found odd. I'm wondering, how would it know when to send traffic upwards? I did try enable mac address cloning of my laptop (Which connects fine) and no dice. –  Zombies Dec 25 '13 at 0:27
    
@Zombies I have edited my answer to gsuggest a different solution to your problem. –  MariusMatutiae Dec 25 '13 at 5:38
    
Edit, or the second answer is what fixed the issue. I changed my routers IP address to 192.168.2.55 ..the 55 just being arbitrary, I'm sure it would also work as 192.168.2.55 and I set the connection type BACK to gateway (default) mode. –  Zombies Dec 25 '13 at 7:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.