Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just had the strangest issue at the BIOS a few moments ago. I had reinstalled a fresh Linux all day and was signing off when I realized I couldn't boot into anything. I tried my two hard drives, my SSD and my rescue flash drives and only got a black screen with a blinking cursor - no error message whatosever, just darkness. The boot sequence just would not start.

Fiddling a bit with the boot options in the BIOS I eventually grew desperate and tried to boot into every single one of my media, one after the other. Eventually I got to booting into my CD-ROM device, and... was dropped into the bootloader for my SSD. It seems my drives swapped places from the BIOS's perspective, but somehow were not relabelled, causing great confusion (and anguish).

Sure enough, I quickly checked afterwards, and the order had changed. For instance, before, the usual order (sda-sdb-sdc) was HDD1-HDD2-SSD. Now it's inexplicably become SSD-HDD1-HDD2, for no apparent reason!

So now I have a few questions. One, how could this have happened? I didn't physically fiddle with the internal drives, so why would they suddenly decide to swap places? Secondly, why did my BIOS behave so erratically and not recognize that the drive names no longer mapped to their original "location"? Surely it would relabel them and not mislead the user like this. And three, has this ever happened to anyone? It's kind of hard to google but I did not find any reports of anything similar on the net, I only found reports of the BIOS changing its boot order which is not quite what is happening here.

(I am now afraid to reboot fearing I might not be able to "get back")


PS: this happened long after the new OS was installed, and I rebooted myriad times between now and then (mostly setting stuff up and doing some tweaking) without this happening. So while there could conceivably be a connection between the two events, I don't really see it. I didn't do anything major just before I rebooted the last time.

share|improve this question
    
I got no answer for how this could have happened, but I can tell you how to avoid it in the future. Use blockIDs per drive, not hardcoded paths. (Link example for arch linux, but it applies to all distributions). –  Hennes Dec 24 '13 at 13:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.