Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There's a random line going through my code in Geany, and it persists to stay there upon restarting the application. How do I remove it?

Screenshot: enter image description here

share|improve this question
    
Which one is the random line? Do you have the line in the document when you open it in some other text editor, gedit perhaps? –  Varaquilex Dec 24 '13 at 17:07
    
The random vertical line near the right side. This only happens in this application. –  zeldarulez Dec 24 '13 at 17:39

5 Answers 5

up vote 4 down vote accepted

Try this: Peferences -> Editor -> View/Display (or something like that, it's called "ansicht" in german) and there deactivate the line-break-help (Umbruchhilfe).

share|improve this answer
    
Perfect! That removed the revolting line in the middle of my code. Thanks for your help ;) –  zeldarulez Jan 11 at 4:23
2  
Edit>Preferences>Editor>Display>"Untick" the option "Long Line Marker" [for latest release 1.22 by the moment] –  Cody Aug 14 at 7:20

It's a text editor, so they're showing you where the (old standard) 72-character line break would be (in case you had line-break turned on, or plan to open the text file in a legacy text editor).

More info:

Wikipedia - Characters Per Line:

At the end of the typewriter age, most designs were geared toward 72 CPL, derived from a pitch of 12 characters per inch, multiplied by 6 inches (see for example IBM Selectric). This would ensure at least 1 inch for each margin, with the U.S. government at the time having standardized on 8 1/2×11" paper. Early computer text editors used this measure as a baseline for their terminal interfaces.

Geany's docs:

Line breaking column - The editor column number to insert a newline at when Line Breaking is enabled for the current document.

enter image description here

It doesn't look like there's a specific option to turn the indicator off, but perhaps setting it to column 0, or to something like 5000 might keep it out of sight at least. :)

share|improve this answer
    
+1 for beating me by 6 seconds, and with a screenshot too. :) –  Ilmari Karonen Dec 24 '13 at 18:00

I don't know how to get rid of the line, but I can guess why it's there.

If I'm counting the characters in your screenshot right, the line seems to be placed after column 72, which has traditionally been considered the maximum "safe" line length. Many text editors, if told to wrap lines, will do so at 72 characters per line by default.

Obviously, your editor isn't doing so (at least not in the mode you're using), but it's warning you that any lines of code that extend past that column might be too long to be viewed on one line without scrolling or wrapping in some cases (e.g. on a 80-column terminal, with a few columns taken up by line numbers).

You can probably turn off the warning line, or adjust its position, in your editor's settings.

See also:

share|improve this answer
    
+1 for the additional references. :) –  Ƭᴇcʜιᴇ007 Dec 24 '13 at 18:01
    
+1 for add. references, too! –  Varaquilex Dec 25 '13 at 0:40

That, my friend, is the vertical line for 72 characters (Thanks for mentioning @techie007). It's a coding convention for wrapping the line for better readability. There are also other conventions, one of them originates from IBM's punch cards, as explained in this programmers.stackexchange question.

Wikipedia mentions the 80 character limit too.

Cultural Impact

  • A legacy of the 80 column punched card format is that a display of 80 characters per row was a common choice in the design of character-based terminals. As of November 2011 some character interface defaults, such as the command prompt window's width in Microsoft Windows, remain set at 80 columns and some file formats, such as FITS, still use 80-character card images.
share|improve this answer
1  
I counted, it's not at the 80th col. ;) –  Ƭᴇcʜιᴇ007 Dec 24 '13 at 18:01
    
That is why you get a +1 from me :P –  Varaquilex Dec 24 '13 at 18:02

The line breaker can be turned off by navigating to: Edit>Preferences>Editor>Display>"Untick" the box named "Long Line Marker"

share|improve this answer
    
this is the way for the latest release ! –  Cody Aug 14 at 7:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.