Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm sharing a couple of directories via samba from my Linux machine, and have no problem seeing them from other Windows XP boxes on the network.

Now I'm running Windows 7 as a virtual machine via VirtualBox, but I can't figure out how to connect to one of those shares. Is it possible? Is there a better way to get access to the file system on the host from a virtual machine?

share|improve this question
    
What are the VMs network settings? –  John T Nov 12 '09 at 0:43
    
Adapter 1 is enabled, attached to "NAT". –  chris Nov 12 '09 at 3:17

2 Answers 2

up vote 1 down vote accepted

Do you have the Windows 7 Guest additions installed? I would just start the VM and select form the VM Menu Bar, Devices -> Shared Folders - you use a simple dialog allowing you to select a path on your local machine. You can choose to make it permanent or read only.

Once you do that, you can map any of them from Windows Explorer. Select Tools -> Map Network Drive and select from the VirtualBox Shared Folders section.

This doesn't access the samba share directly, but it works. Not sure if you'll experience a performance problem with this approach.

share|improve this answer
    
That did the trick! Thanks. –  chris Nov 12 '09 at 22:54

By using NAT, Virtualbox is acting as a router, and the virtual machine is therefore hidden from the world outside its router - including your network.

Try setting the network to "bridged", in this way the virtual machine uses your physical router as its router and will appear as a normal machine on your network.

share|improve this answer
    
I tried that, and still can't see anything. It does see the Linksys router, but can't see any other machines on the network. Is Win7 Home networking limited to the "homegroup" stuff, which seems to only apply to Win7 computers? –  chris Nov 12 '09 at 22:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.