Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This laptop - Asus X551CA, does not have any optical drive, and I am trying to boot it from USB, so I could install an OS to it, because its newly bought and has no OS in it.

My USB is perfectly bootable, but still, even on the BIOS setup, or when I press ESC at the system start, my USB does not appear as an option to boot from.

Can somebody help me out please?

share|improve this question
possible duplicate of Asus UEFI/BIOS options - How to boot from DVD? – and31415 May 30 '14 at 19:10

That might be similar to your situation..

Under Security disable Secure Boot Control

Under Boot disable Fast Boot, then enable Launch CSM, then enable Launch PXE OpROM

Save changes and restart and press the esc key and choose boot from USB.

If that doesn't least you have somewhere to start looking.

share|improve this answer
Thank you for you answer, I can enable Launch PXE OpROM, but under Security the only options I see are under I/O Interface Security like LAN and CardReader Interface, Wireless Network Interface, USB Interface Security etc. I can not find the option Secure Boot Control. – uklp Dec 25 '13 at 12:37
Thanks, it helps me with Asus NJ551 – Павел Шорохов Jul 20 at 12:43

Plug in your USB boot device hold down Esc key it should come up with your USB boot device in the list, select it and off you go.

Good luck, just make sure secure boot is disabled in BIOS!

share|improve this answer

To find the Secure Boot control you have to update the BIOS to the latest version To do it, download the file and put it on your USB Root Directory Next go into BIOS and then look for Advanced\Easy Flash And look for the update file in the root directory AKA F:0 or something. Install it and stuff, then reboot into BIOS and try disabling secure boot again

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .