Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed the Emacs Prelude as suggested in https://github.com/bbatsov/prelude . I find the background-color grey of the Zenburn theme to be disturbing. I wish to change the background-color to black. I tried (set-background-color "black") ,but it is not working. The background-color still remains grey. Can someone help on how to fix this ?

share|improve this question

2 Answers 2

It looks like the Zenburn theme uses the zenburn-colors-alist: https://github.com/bbatsov/zenburn-emacs/blob/master/zenburn-theme.el

The colors can be manually modified by placing this inside your .emacs file and changing the colors as you see fit.

(setq zenburn-colors-alist '(
  ("zenburn-fg+1" . "#FFFFEF")
  ("zenburn-fg" . "#DCDCCC")
  ("zenburn-fg-1" . "#656555")
  ("zenburn-bg-2" . "#000000")
  ("zenburn-bg-1" . "#2B2B2B")
  ("zenburn-bg-05" . "#383838")
  ("zenburn-bg" . "#3F3F3F")
  ("zenburn-bg+1" . "#4F4F4F")
  ("zenburn-bg+2" . "#5F5F5F")
  ("zenburn-bg+3" . "#6F6F6F")
  ("zenburn-red+1" . "#DCA3A3")
  ("zenburn-red" . "#CC9393")
  ("zenburn-red-1" . "#BC8383")
  ("zenburn-red-2" . "#AC7373")
  ("zenburn-red-3" . "#9C6363")
  ("zenburn-red-4" . "#8C5353")
  ("zenburn-orange" . "#DFAF8F")
  ("zenburn-yellow" . "#F0DFAF")
  ("zenburn-yellow-1" . "#E0CF9F")
  ("zenburn-yellow-2" . "#D0BF8F")
  ("zenburn-green-1" . "#5F7F5F")
  ("zenburn-green" . "#7F9F7F")
  ("zenburn-green+1" . "#8FB28F")
  ("zenburn-green+2" . "#9FC59F")
  ("zenburn-green+3" . "#AFD8AF")
  ("zenburn-green+4" . "#BFEBBF")
  ("zenburn-cyan" . "#93E0E3")
  ("zenburn-blue+1" . "#94BFF3")
  ("zenburn-blue" . "#8CD0D3")
  ("zenburn-blue-1" . "#7CB8BB")
  ("zenburn-blue-2" . "#6CA0A3")
  ("zenburn-blue-3" . "#5C888B")
  ("zenburn-blue-4" . "#4C7073")
  ("zenburn-blue-5" . "#366060")
  ("zenburn-magenta" . "#DC8CC3")))
share|improve this answer

You can also dissable the zenburn theme:

M-x disable-theme

More info here: How to disable EMACS - Prelude colors? (terminal)

And here: https://github.com/bbatsov/prelude#ugly-colors-in-the-terminal-emacs-version

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.