Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

UAC is activated for the administrator. With Windows 8 everything is okay. After the upgrade to 8.1, the administrator account is denied to access the every partition except the one containing Windows, Users, Program Files, etc.

The message is the same as when a regular user is denied access to whatever folder. It is impossible to see and change ownership and permissions.

Same error for every user belonging to the Administrators group, even a user created for the test after the upgrade.

When we deactivate UAC for the administrator, access is okay. But then we can no longer perform some actions, so UAC is important for us.

Update:

  • the permissions already grant full access to the Administrators group
  • chkdsk reveals no error
share|improve this question
    
While deactivating UAC you can change permissions then you can try to change all permissions and then reactivating the UAC. –  Hunter Dec 27 '13 at 16:16
    
You talking about local admin account or domain admin account? If its domain admin, I guess you'll have to add it again to Administrators group of that PC after the update. –  tumchaaditya Jan 2 at 17:27
    
Are you talking about other partitions on local disk(s), or are you talking about network shares? –  Scott Jan 2 at 18:43
1  
I also found a discussion here which may help: think-like-a-computer.com/2011/05/11/… –  tumchaaditya Jan 2 at 19:50
add comment

3 Answers

up vote 7 down vote accepted
+200

You may have restricted the permissions on your partitions to keep access only for administrators.

If this is the case, you face a Windows's bug. This bug is since Windows 7 I think. Seems nobody found a clean way to avoid it. Some people sais this is a bug into Explorer, but the command line exhibit the same behavior, as PowerShell, as other applications I tested.
It only fire when UAC is enabled and you belong to the Administrators group and the folder is restricted to the Administrators group only.

If you want to keep UAC, you have to modify the permissions to allow someone else to read the folders you want. Remember: this user must not belong to the Administrators group.
Personaly I create a special user for this usage only.

To modify the permissions, you may have to disable UAC. Once done, you enable it.

share|improve this answer
2  
I had "Administrators" + "System" as only access to the partitions. I added "Authenticated Users" read-only and everything is okay. For me the bug is only at the root of each partition. –  Gregory MOUSSAT Jan 2 at 21:26
add comment

Check first the date and time of the computer. If incorrect, set and reboot.

Then, check the owner account of the other partitions. If incorrect, reset it to its correct value.

I would even re-grant the accounts and group permissions on these partitions, even if they already exist, to refresh them to their correct values.

One of the many articles treating such changes is this link.

share|improve this answer
add comment

You might want to run the chkdsk command on the disk with the other partitions on it, the security descriptors may have gotten messed up in the update, which chkdsk can check and repair.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.