Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The display name of my OS drive in Windows 7 (64 Ultimate) won't display as the name I've renamed it via properties, Diskpart and manually. What is going on!

As you can see in My Computer it is named Drive g even though Disk Manager knows it is OS.

enter image description here

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It's being named by a hidden file autorun.inf.

First, you'll need to view the hidden file by selecting the option in Control Panel - Folder Options - View tab - Hidden files and folders - Show hidden files, folders, and drives.

Next, navigate to My Computer - drive you want to rename and find autorun.inf

enter image description here

Now, just delete the autorun.inf file and voila!

enter image description here

share|improve this answer
2  
The more interesting question IMO is, why/how did it happen? –  nitro2k01 Dec 27 '13 at 12:30
    
@nitro2k01 I think it happened when I was swapping the storage HDDs, I accidentally swapped the OS disk (because I didn't remember in what order they were physically) and for some reason, it decided Drive g was appropriate when I reconnected it. –  Raystafarian Dec 27 '13 at 12:33
    
Doesn't worked for me. Is this method only for windows 7 64-bit or can be used on windows 8 32-bit as I renamed the drives and they changed right away. Also I can't see any file named "autorun.inf". –  Hunter Dec 27 '13 at 15:36
    
@Hunter you need to show hidden files to see it. –  Raystafarian Dec 27 '13 at 17:12
    
@Raystafarian Did it and also unchecked the hide unprotected system files thing to make sure if the autorun.inf file was system protected. But didn't see it. –  Hunter Dec 28 '13 at 10:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.