Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange problem and I'm wondering if there's an answer to said problem.

I connect thru the company network (using SonicWall Aventail) and while most applications are super fast, some of them, and especially one application, is VERY slow to respond. However, when I'm at work, locally, said application is super quick.

  • OS @ work = Windows 7 Enterprise x64
  • Specific slow application = SDLX 2007 (x86 application)
  • OS used @ home to connect thru RDP = Windows 7 Ultimate x64
  • Internet connection speed = 15Mbps

Here's what I've tried to far :

  • Disable every single "eye candy" on remote computer
  • Disable Aero cursor, sound, printer, everything, except network drives
  • Once connected, I've use RDP directly to connect to my computer at work instead of clicking the link "Connect to my computer" on the company website
  • Disable "splwow64" thru registry tweak

... all the above did nothing to improve the speed of SDLX.

I think it's important to mention that SDLX is a very old 32bit application (it says 2007, but it's really just the 2005 version, with patches) so maybe that's why it's so slow in RDP. The only thing that doesn't "click" in my head is... why is it so fast when I'm at work and so slow when I work from home when everything else is fast in RDP ?!

Another thing worth mentionning, I connect to another computer from home in RDP, but that computer is on Windows XP x86 and SDLX is lightning fast on that computer, even remotely, so I'm beginning to think that it's related to either Windows 7 or a x64 vs. x86 OS...

Any idea why ? Any idea how to fix this problem ? :)

share|improve this question
    
Are you RDPing to a desktop, and then running the program, or it is being delivered as a RemoteApp? Have you tried the RDP with local resources like drives and printers disabled (before connecting)? If you use a Windows 7 machine at work to RDP into the server and run the program, does it behave any better than your Win7 at home? –  techie007 Dec 27 '13 at 15:12
    
No, it's a local app on my desktop at work, it's not a RemoteApp. As for the program, if I RDP into the Win7 machine FROM WORK, the application is still slow as hell in RDP, while being super fast if I use it directly, so I doubt it's something related to my computer at home. The more I think about it, the more I'm inclined to think that it's related to the SysWow64 "emulator" within the x64 OS trying to run 32bit DLLs... the problem is, I have no idea whatsoever on how to fix this :( –  d5t6 Dec 27 '13 at 15:48
    
No DLLs or alike will be run on the local machine -- that's how RDP works. What is the host machine's OS? Have you checked th elocal resources as I suggested? How about adjusting things like resolution and colour-depth in the RDP settings before you connect? Any effect? –  techie007 Dec 27 '13 at 16:11
    
As I mentionned in my original post, I tried to disable every "eye candy" options + mouse cursor, printers, everything except network drives. I even tried 8bit colors ! All this did nothihg to improve the speed of the faulty application. –  d5t6 Dec 27 '13 at 17:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.