Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just upgraded to Windows 8.1. I like my desktop to hibernate when I am not home (I have an old PC and it overheats). As much as I have tried I cannot get it to hibernate (or Sleep, for that matter) after an idle period.

Starting with the default settings the computer tried to enter sleep after the 120 minutes of inactivity. It promptly woke up. I checked the event logs and found:

The system has returned from a low power state.
Sleep Time: ‎2013‎-‎12‎-‎29T03:50:01.191479100Z
Wake Time: ‎2013‎-‎12‎-‎29T03:50:09.399234600Z
Wake Source: Device -USB Root Hub

I disabled my mouse from waking the computer (in Device Manager). I also enabled Hibernate in the power settings. From this point onwards the computer has no longer attempted to go to sleep.

I ran:

powercfg /requests  

This came back with None for everything. I have reset my power plan, but it just won't go to sleep or hibernate on its own. I can manually hibernate the PC, so the process works. I just want to be able to leave my computer and have it power down nicely.

This is the output of running the command: powercfg -devicequery wake_armed

Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller
HID Keyboard Device  

The running processes in Task Manager (Sorry for the links, I do not have sufficient rep to add images):

http://i.imgur.com/jRqLngo.png

http://i.imgur.com/kPxkVfA.png

Okay, culprit found. I disabled my NIC in Device Manager and suddenly my insomniac PC slept! I installed the legacy Windows 7 drivers for this Ethernet adaptor and now my computer sleeps perfectly.

Follow up edit after a while my computer stopped hibernating again. Disabling the NIC fixed the problem. Obviously this older hardware doesn't want to play with Windows 8.1. I have now added a Scheduled Task set to run after 1 hour of idling:

shutdown /h

This seems to work. It will not hibernate when I am watching a movie but will wait until VLC/YouTube stops playing. Seems like a decent enough work around.

share|improve this question
    
post the out put of POWERCFG /DEVICEQUERY wake_armed –  magicandre1981 Dec 30 '13 at 6:44
    
Edited as requested. I have also removed my ethernet adaptor and keyboard from the allowed devices. –  hsimah Dec 30 '13 at 8:13
    
and does it work now with both devices disabled? –  magicandre1981 Dec 30 '13 at 16:33
    
Nope. My computer is just turning the monitors off as per the power scheme settings. No hibernation. Is there any other info I can share to help? –  hsimah Dec 30 '13 at 21:52

1 Answer 1

up vote 0 down vote accepted

To fix this issue I installed the Windows 7 64 bit drivers for my NIC (Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller). This overwrote the Microsoft drivers that Windows was using. Now my PC sleeps as per the power configuration. This isn't a great solution, but it works for me. If anyone knows of a better way to do this, I will try it. I am thinking some sort of powercfg /requestsoverride for the NIC or something.

The powercfg utility was very helpful in pointing me in the correct direction for this. My mouse was also keeping the PC awake.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.