Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I am trying to get a word suggestion in vim with CTRL + x CTRL + s VIM hangs and makes it unresponsive. I am using vim 7.3 and I have a custom spellfile: https://github.com/kaleb/vim-files/tree/master/spell

Question:

Is there some trick to make this not hang and allow me to use the spell menu?

For a bonus, how do I get out of the unresponsive state? ESC and CTRL + c do not seem to do the trick.

share|improve this question
up vote 4 down vote accepted

This had something to do with terminal treating CTRL+s as XOFF, which means the terminal will continue to take input but display won't change.

Do CTRL+Q, this unhangs vim.

To disable this kind of behaviour you can put this in your .bashrc

stty ixany
stty ixoff -ixon

I believe you can type reset to load those configurations. Else logout-login. Else reboot :)

share|improve this answer
    
SPESHUL thanks to raamdev.com/2007/recovering-from-ctrls-in-putty – brunch875 Dec 31 '13 at 18:16
    
I knew about ctrl-s, and didn't think about it. Thanks! – kzh Dec 31 '13 at 18:46

If you are unable to resolve terminal setting conflicts with vim, you can use gvim or mvim, the GUI interfaces to vim. There is also MacVim if you're running OSX.

share|improve this answer

CTRL + s suspends terminal transmission. If you do not want to shut this feature off in your terminal, you can issue the following vim command: CTRL + x s. Make sure you are not holding down the CTRL key when you hit the s key.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .