Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two laptops, one an XP machine, and one a newer Windows 7 64 bit machine. On both I have Visual Studio 2008 Team System installed, same service packs.

When I work from home I can connect to our office network over the VPN from both machines, and ping the Team Foundation Server machine from both. However I can only connect Visual Studio to TFS from my older XP machine. On the Win7 machine VS 'cannot find' the TFS server.

I am at a loss to know what to do to resolve this. Can anyone advise? It does not seem to be a port/firewall issue because my home router is common, and the VPN is common, so I suspect that TFS or my Win7 laptop have to have something set up to allow the connection - but what? Does TFS for example need to be told that my Win7 laptop will connect remotely or something?

I do not have a happy band of network administrators to assist - I am all on my own on this one, and I have to find a resolution.

share|improve this question

3 Answers 3

Make sure the VS 2008 is allowed to make outgoing connections in Windows firewall.

Compare result of route print on both machines. Perhaps the target IPs are the same, but the machines are actually different? Both answer to ping, but only one is the TFS server.

Alternatively use tracert to see how and where the connection goes on both machines.

share|improve this answer
    
What port would that be? I presume this means the firewall on the offending client machine (my home router/firewall doesn't interfere in this way) –  Neil Haughton Jan 2 at 16:19
    
Doh! port 8080, of course. –  Neil Haughton Jan 3 at 9:40
    
XP machine connects at home and office, but Win 7 does not at home (but does at work). Does that not mean that the Windows firewall on the Win 7 machine must have port 8080 open? Otherwise how could VS connect from it when at work? –  Neil Haughton Jan 3 at 18:33
    
tracert shows: from me > 10.1.1.113 > devserver2. I am using the 192.168 subnet at home, so these are both at the office end –  Neil Haughton Jan 3 at 18:37
    
Have you tried running the VS on Win7 with administrative permissions? –  Dariusz Jan 3 at 18:59

A few questions. Answering these should show you the direction you need to go:

  • Is your TFS server setup to use domain credentials?
    • If yes, is your new laptop a part of the same domain?
    • If no, then this is not the problem
  • Can you ping the TFS server once connected to the VPN?
    • If yes, then it is an issue with your VS2008 setup, or a credentials issue
    • If no, is the TFS server located on a different subnet than the one your VPN uses?
  • Are you connecting to the correct port on the TFS server? Compare your old config to the new one.

For some reason my gut tells me its a domain authentication issue, but I could be wrong. Assuming it is setup properly, there are very few things that will prevent the TFS server from letting you connect. You could setup TFS to only allow certain computers to connect, but that would be a very unorthodox way of allowing access, most places give access via a domain account.

share|improve this answer
    
1. yes, we always use domain credentials to connect. 2: yes it is. 3: yes I can. VPN works fine from home. It is only VS that has a problem from home, on Win 7. –  Neil Haughton Jan 2 at 16:18
    
Can you access the TFS web server from its URL. Similar to h ttp://TFSserver:8080/tfs/ –  Lee Harrison Jan 2 at 16:41
    
You'll have to help me a little before I can test this. Do you mean over the VPN? If so, I will try tonight and get back to you. I think the url should be h ttp://devserver2:8080/tfs (devserver2 being the TFS machine name that VS is set up to connect to in the office), but I can't do this from my machine when in the office. After entering my domain credentials (in Firefox, but not needed in IE) I get a 404 page-not-found message. If I can't do it in the office I won't be able to do it from home, I guess. –  Neil Haughton Jan 3 at 9:39
    
You TFS server may not have been setup to allow web access, which is a shame because there is some great functionality there. However, the fact that you are prompted for credentials should be enough to verify that you are in fact hitting the TFS web server. If you enter improper credentials do you get a 403 error instead of a 404? –  Lee Harrison Jan 3 at 14:26
    
Another thing worth trying from home is just using the IP address of the TFS server. If that works, you could be looking at a DNS issue over your VPN. Also, what is the exact message that VS is giving when connecting fails? –  Lee Harrison Jan 3 at 14:28
up vote 0 down vote accepted

In the end I managed to get a network guy to investigate, and it turned out to be the VPN connection was set to use the default gateway, ie the office gateway instead of my home router. Changing that solved the Team System problem and a host of other oddities as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.