Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is my terminal output:

# dpkg -i skype-debian_4.2.0.11-1_i386.deb 
Selecting previously unselected package skype.
(Reading database ... 148114 files and directories currently installed.)
Unpacking skype (from skype-debian_4.2.0.11-1_i386.deb) ...
dpkg: dependency problems prevent configuration of skype:
 skype depends on libasound2 (>= 1.0.16); however:
  Package libasound2:i386 is not installed.
 skype depends on libc6 (>= 2.3.6-6~); however:
  Package libc6:i386 is not installed.
 skype depends on libc6 (>= 2.7); however:
  Package libc6:i386 is not installed.
 skype depends on libgcc1 (>= 1:4.1.1); however:
  Package libgcc1:i386 is not installed.
 skype depends on libqt4-dbus (>= 4:4.5.3); however:
  Package libqt4-dbus is not installed.
 skype depends on libqt4-network (>= 4:4.8.0); however:
  Package libqt4-network:i386 is not installed.
 skype depends on libqt4-xml (>= 4:4.5.3); however:
  Package libqt4-xml:i386 is not installed.
 skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
  Package libqtcore4:i386 is not installed.
 skype depends on libqtgui4 (>= 4:4.8.0); however:
  Package libqtgui4:i386 is not installed.
 skype depends on libqtwebkit4 (>= 2.1.0~2011week13); however:
  Package libqtwebkit4:i386 is not installed.
 skype depends on l
dpkg: error processing skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
 skype


# apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  skype:i386
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 39.2 MB disk space will be freed.
Do you want to continue [Y/n]?

I amd64 architecture and I also added i386 using "dpkg - add-architecture i386".

Is there any way to fix it?

EDIT:

# apt-get install libasound2:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libasound2:i386 : Depends: libc6:i386 (>= 2.7) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

# apt-get install libc6:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  audacity-data discover-data eclipse-platform-data hp-ppd javascript-common klibc-utils libasm3-java libaspectj-java libcommons-cli-java libcommons-codec-java libcommons-dbcp-java libcommons-httpclient-java
  libcommons-lang-java libcommons-pool-java libeasymock-java libecj-java libequinox-osgi-java libfelix-bundlerepository-java libfelix-osgi-obr-java libgeronimo-jta-1.1-spec-java libgoocanvas-common
  libhamcrest-java libicu4j-4.4-java libjetty8-java libjs-xmlextras libklibc libkxml2-java libmlt-data libosgi-core-java libosgi-foundation-ee-java libservlet3.0-java libtomcat7-java logcheck-database
  mysql-common wwwconfig-common
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libc6-i686:i386 libgcc1:i386 multiarch-support:i386
Suggested packages:
  glibc-doc:i386 locales:i386
The following packages will be REMOVED:
  accountsservice acl acpi acpi-fakekey acpi-support acpi-support-base acpid adduser aisleriot alacarte alsa-base alsa-utils anacron ant ant-optional apache2.2-bin apg apt apt-listchanges apt-utils


!!! here were a lot of packages !!!


  xserver-xorg-video-vmware xserver-xorg-video-voodoo xterm xulrunner-17.0 xz-utils yelp zeitgeist-core zenity zlib1g
The following NEW packages will be installed:
  libc6:i386 libc6-i686:i386 libgcc1:i386 multiarch-support:i386
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt libapt-pkg4.12 (due to apt) libc6 (due to apt) libgcc1 (due to apt) libstdc++6 (due to apt) debian-archive-keyring (due to apt) gnupg (due to apt) base-files base-passwd bash debianutils (due to bash)
  dash (due to bash) libtinfo5 (due to bash) bsdutils coreutils dpkg (due to coreutils) install-info (due to coreutils) libacl1 (due to coreutils) libattr1 (due to coreutils) libselinux1 (due to coreutils)
  diffutils libbz2-1.0 (due to dpkg) liblzma5 (due to dpkg) zlib1g (due to dpkg) tar (due to dpkg) e2fsprogs e2fslibs (due to e2fsprogs) libblkid1 (due to e2fsprogs) libcomerr2 (due to e2fsprogs) libss2 (due
  to e2fsprogs) libuuid1 (due to e2fsprogs) util-linux (due to e2fsprogs) findutils grep gzip hostname login libpam0g (due to login) libpam-runtime (due to login) libpam-modules (due to login) mount libmount1
  (due to mount) libsepol1 (due to mount) ncurses-bin perl-base sed sysvinit initscripts (due to sysvinit) sysv-rc (due to sysvinit) sysvinit-utils (due to sysvinit) tzdata (due to util-linux) debconf (due to
  util-linux) libncurses5 (due to util-linux) libslang2 (due to util-linux)
0 upgraded, 4 newly installed, 1681 to remove and 0 not upgraded.
Need to get 5,358 kB/5,411 kB of archives.
After this operation, 3,116 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?]
share|improve this question
    
what does it mean I have amd64 with added i386? Please post the output of uname -a –  MariusMatutiae Jan 2 at 18:32
    
What happens if you try to install the missing librries one by one? Please post output. –  MariusMatutiae Jan 2 at 19:02
    
@MariusMatutiae added output from terminal to the question –  AbitDeveloper Jan 2 at 19:30

3 Answers 3

Nowadays, you install skype on Debian by enabling MultiArch, then installing the i386 package, as follows:

   dpkg --add-architecture i386
   apt-get update
   wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
   dpkg -i skype-install.deb

If you still cannot install the package, it means you have not set the repos. Add most, or all, of the following lines (as sudo) to your /etc/apt/sources.list file:

   deb http://ftp.us.debian.org/debian/ wheezy main contrib non-free
   deb http://security.debian.org/ wheezy/updates main contrib non-free   
   deb http://ftp.us.debian.org/debian/ wheezy-updates main contrib non-free 
   deb http://ftp.us.debian.org/debian/ wheezy-proposed-updates main contrib non-free
   deb http://ftp.debian.org/debian/ wheezy-backports main      

then run

   sudo apt-get update

and try the first four lines again.

share|improve this answer
    
still same problem –  AbitDeveloper Jan 2 at 19:00
$~ wget http://ftp.us.debian.org/debian/pool/main/a/alsa-plugins/libasound2-plugins_1.0.25-2_i386.deb

$~ mkdir /tmp/deb-temp
$~ dpkg-deb -x libasound2-plugins_1.0.25-2_i386.deb /tmp/deb-temp
$~ su - (your root password) or sudo su - (your password)
root $~
root $~ cp -a /tmp/deb-temp/usr/lib/i386-linux-gnu/alsa-lib /usr/lib/i386-linux-gnu/
root $~ touch /etc/ld.so.conf.d/zz_i386-alsalibasound-plugins.conf 
root $~ vi /etc/ld.so.conf.d/zz_i386-alsalibasound-plugins.conf

# make the file contents looks like:
# Legacy biarch compatibility support
/usr/lib/i386-linux-gnu/alsa-lib/

# save your file. Run: 

root $~ ldconfig
share|improve this answer

for Wheezy use Ubuntu Lucid package. that works. latest has unsolvable deps. su too root in terminal in directory containing deb (download from skype.com) type dpkg -i then apt-get -f install to pull down dependencies. Or use Gdebi package installer.

share|improve this answer
    
Can you please expand your answer and explain how to use the Ubuntu Lucid package? –  slhck Mar 7 at 21:12
    
Download the deb for Ubuntu 10.04 Lucid. Open a root terminal in download directory and type dpkg -i packagename.deb. Gdebi should work too. Use repositories as above. I don't think backports are needed but will not do any harm as main repos are preferred by apt. –  stein Mar 7 at 21:18
2  
Please edit your answer instead of posting it in a comment below. –  slhck Mar 7 at 21:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.