Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I once opened Transmission in some computer in the computer centre of my institute, and maybe forgot to exit Transmission and locked the screen. Then on some later day I log in from another computer in the computer centre, and whenever I try to open Transmission from some computer I get a message box with the following message:

Transmission is already running,but not responding. 
To start a new session you must first close existing Transmission process.

I have tried the command: kill -9 transmisson. I tried top, but that also didn't show any Transmission ID. I know how to get rid of it in the case of Firefox. The command for Firefox is rm -rf .mozilla/, but in the case of other applications, I don't know what to do.

share|improve this question

1 Answer 1

You cannot see the process because it is running on a different machine.

You should stop it on the same machine you started the process.

Edit

BTW try first a clean shutdown with kill without the -9. Otherwise the open lock files will not be removed.

share|improve this answer
    
But I think it has got frozen. Now every computer is showing the same pop up. –  user22180 Jan 3 at 9:53
    
The pop up appears since transmission is detecting some lock files. Did you check on every machine if the process is running? –  Matteo Jan 3 at 10:10
    
kill or kill -9 gives following. bash: kill: transmission: arguments must be process or job IDs That is why I tried "top" to find Id. but didn't find transmission there –  user22180 Jan 3 at 11:20
    
Either use killall transmission or find out the PID (process ID) with ps and then kill PID –  Matteo Jan 3 at 11:25
    
the problem still persists. here is the output of the commands $ ps Output:" PID TTY TIME CMD 14241 pts/0 00:00:00 bash 14547 pts/0 00:00:00 ps" $ killall transmission output:transmission: no process killed $ kill 14241 $ kill 14547 output:bash: kill: (14547) - No such process –  user22180 Jan 3 at 11:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.