Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Visual C++ 2008 installed in Windows XP. Compiled applications doesn't work in Windows 98 SE. How do I configure my compiler that it compiles Windows 98 compliant applications in Windows XP?

Extra question:

If it is not possible in Visual C++ 2008, how can I achieve the same in older Visual C++ releases?

share|improve this question
    
I think you have compile the application for the multi-byte character set (MBCS). It will not work when compiled as Unicode. –  avirk Jan 3 at 15:52
    
The simplest way would be to use a non-Microsoft C++ compiler. There is no way to get Visual C++ 2008 Redistributable to work on Windows 98 SE. This also applies to any of the more recent versions of the Visual C++ redistributable. –  Ramhound Jan 3 at 15:54

2 Answers 2

up vote 3 down vote accepted

I think you're going to have to revert to Visual Studio 6.0. I'd be surprised if you can find a copy to use.

share|improve this answer

Microsoft Visual Studio 2008 is designed for all .net products upto .net 3.5. If you are compiling your product to a .net 3.5 application, then it will not work in Windows 98 SE since Win 98 SE supports only .net 1.0 and 1.1

share|improve this answer
    
thanks. how do i make VS to compile specific .net version application? –  user2543574 Jan 4 at 14:05
    
In the solution explorer of visual studio, you can find out the properties option of your project. Open the properties. There you can find out the target framework to which the current project needs to be built. –  Aron Sajan Philip Jan 5 at 15:14
    
i can not change target framework version. it is set to .net 3.5. why? –  user2543574 Jan 6 at 10:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.