Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using version 7.1.138 on Ubuntu 8.04, on this machine ciw - change inner word command does not work. No custom settings is done to vim. Does someone know why?

share|improve this question

migrated from stackoverflow.com Nov 12 '09 at 19:06

This question came from our site for professional and enthusiast programmers.

1  
FWIW: :ver will tell you the features compiled into vim. It may be that textobjects is turned off in your build. –  Laurence Gonsalves Nov 12 '09 at 0:03
add comment

2 Answers

Open Vim and enter

:version

to see if textobject has been enabled at compile time in your version of Vim.

share|improve this answer
    
Yes, there we have it. Features included (+) or not (-): -textobjects. –  jnstq Nov 12 '09 at 8:25
    
The next question is, how does i enable textobjects? –  jnstq Nov 12 '09 at 10:26
    
@jnstq, Sorry mate. That's a compile time options afaik. –  Rob Wells Nov 12 '09 at 10:32
5  
Don't (never?) use a lite-version of vim. On some distributions, starting vi instead of vim will start vim is a degraded lite-mode. –  Luc Hermitte Nov 12 '09 at 15:38
    
@Luc, superbe! I was wondering about why I was getting the reduced vi by default. +1 –  Rob Wells Nov 12 '09 at 17:31
add comment

Debian/Ubuntu install vim-tiny by default. Installing the vim package gives you the full version. There's also vim-gnome (previously vim-full) which includes the full version as well as a GUI version. As far as I know (and there's nothing about this in the man page), vim behaves the same regardless of whether you invoke it as vi.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.