Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have gcc-4.6.1 installed in my Ubuntu 11.10 system. For compiling some other software I require gcc-4.0. I download the gcc-4.0.0 tar file and extracted it. I created a new folder and ran the configure file (without any options) from the gcc-4.0.0 directory. Everything worked fine till here.

But when I try to make, I get the following error:

  Configuring in fastjar
configure: creating cache ./config.cache
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
configure: error: source directory already configured; run "make distclean" there first
make: *** [configure-fastjar] Error 1

I tried running make distclean in gcc-4.0.0 but again I get the following error:

make: *** No rule to make target `distclean'.  Stop. 

`

share|improve this question
1  
Ubuntu 11.10 is not supported any longer, you should move on to 12.04LTS or even to 13.10 (not a LTS version). With these versions, you will find no such problems. –  MariusMatutiae Jan 4 at 13:55
    
What version do the repositories have? I have 4.7.2 on PC linux OS –  py_script Jan 4 at 14:08
    
Try 4.0.1. –  terdon Jan 5 at 2:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.