Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I setup TPLINK WDR3600 with openwrt firmware.

I have a modem (192.168.1.253) which I set it to bridge mode and I use a cable from this LAN to the WDR WAN (192.168.1.1). And another cable from WDR to pc.

I can ping from inside WDR (I am connected via putty) but I can't from my browser (the internet conection doesn't work on pc).

ifconfig:

br-lan    Link encap:Ethernet  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:633 errors:0 dropped:0 overruns:0 frame:0
          TX packets:512 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:76468 (74.6 KiB)  TX bytes:74782 (73.0 KiB)

eth0      Link encap:Ethernet 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:22008 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24684 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4654823 (4.4 MiB)  TX bytes:8707067 (8.3 MiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:640 errors:0 dropped:0 overruns:0 frame:0
          TX packets:515 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:77897 (76.0 KiB)  TX bytes:74920 (73.1 KiB)

eth0.2    Link encap:Ethernet  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:87 errors:0 dropped:67 overruns:0 frame:0
          TX packets:9895 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:41394 (40.4 KiB)  TX bytes:3888735 (3.7 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:566 errors:0 dropped:0 overruns:0 frame:0
          TX packets:566 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:59162 (57.7 KiB)  TX bytes:59162 (57.7 KiB)

tap0      Link encap:Ethernet  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4317 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 B)  TX bytes:884846 (864.1 KiB)

wlan0     Link encap:Ethernet  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:64 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:8640 (8.4 KiB)  TX bytes:9920 (9.6 KiB)

/etc/config/network:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option broadcast '192.168.1.255'
    option _orig_ifname 'eth0.1 radio0.network1 radio1.network1'
    option _orig_bridge 'true'
    option ifname 'eth0.1 tap0'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'pppoe'
    option username 'user_isp'
    option password 'password'



config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0t 2 3 4 5'

config switch_vlan
    option device 'eth0'
    option vlan '2'
    option ports '0t 1'

Am I doing sth wrong?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It could be a firewall thing, but more likely ip_forwarding is not set.

See if typing "echo 1 > /proc/sys/net/ipv4/ip_forward" fixes your problem. If it does, add the line "net.ipv4.ip_forward=1" to /etc/sysctl.conf to make this change permanent.

If that doesn't work, please provide an output of route -n; iptables -vnL; iptables -t nat -vnL to show your route table and IPTABLES rules

share|improve this answer
    
:Ok, I will check it tomorrow and I will inform you.Thank you –  George Jan 4 at 21:38
    
:I disabled firewall and it works fine (what settings do i need to chage in order to have firewall?).Also,can you help me setup wireless connection?Or I must open a new post?Thanks! –  George Jan 5 at 11:32
    
:I opened another post if you would like to help. superuser.com/questions/697245/… .Thank you! –  George Jan 5 at 12:19
    
In theory /etc/config/firewall - I generally create an rc.firewall script with "$iptables -F and $iptables -t nat -F" at the top and run it from rc.local or when I make a change. –  davidgo Jan 5 at 17:08
    
:Ok, thank you. ! –  George Jan 5 at 17:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.