Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having performance issues with Windows 7 Home Premium (64-bit) in VirtualBox when I run a resource-intensive program like Adobe Illustrator. Performance is pretty slow, but given my specs and allocation of resources, it should be able to handle such a task. My computer specs are listed below:

-Computer-

Processor : 8x Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz

Memory : 16469MB (1610MB used)

Operating System : Ubuntu 13.10

Resolution : 1680x1050 pixels

OpenGL Renderer : Mesa DRI Intel(R) Ivybridge Desktop x86/MMX/SSE2

X11 Vendor : The X.Org Foundation

-Multimedia-

Audio Adapter : HDA-Intel - HDA Intel PCH

ATA Samsung SSD 840

ATA WDC WD5000AZLX-0

As you can see, I have 16 GB RAM, 8 CPU cores, and hardware virtulization enabled. I have allocated almost 3 GB of ram to Windows, 4 cores, and 72 Mb of Video Memory. This is all running on an SSD. When Windows 7 runs, I am not overloading my CPU, RAM, or other components as I check this on the host machine. As you can also see, I am running only the integrated video card. I don't know if this should affect my performance a lot for Illustrator, but if it does, I would appreciate the heads up.

Why is it running so slow? It constantly runs snails pace on simple operations.

share|improve this question
    
This definitely helps: superuser.com/questions/340348/… –  and0rsk Jan 5 at 1:07
1  
While Photoshop does make use of the GPU, Illustrator does not, so the video-card shouldn’t matter. (Still, just 72MB?) Adobe has a lengthy list of ways to improve Illustrator’s performance, so give that a once over. If that doesn’t help, try tuning the VM’s settings? Finally, you’ll have to be more specific about what you mean by “it runs slow”. What exactly happens? Does it draw slow? Does the guest OS’s CPU go to 100%? –  Synetech Jan 5 at 1:27
1  
Virtualbox along with most virtual products uses a software graphics rendering. That means anything 3D will choke it as the CPU is forced to do the heavy lifting. I suggest maxing the video memory to 128mb. The Mesa driver is 100% software or CPU based graphics. You need to check the host OS for CPU utilization. –  cybernard Jan 5 at 1:35
    
Try using something other than VirtualBox. –  Michael Hampton Jan 5 at 2:55
1  
VMware Player is free, and much more full featured than it used to be. Or if you have a Linux host, use the built in KVM virtualization. –  Michael Hampton Jan 5 at 6:16

1 Answer 1

I experienced this problem on my PC, I thought it was a new version that had made my Windows XP, and Windows 7 Guests.

After much playing around, and finding nothing but other users complaining of same problem, I found the solution for me:

If the OpenGL renderer for the QT engine that VB uses OpenGL, All guests are unbearably slow (except when in text mode). If the renderer is set to RASTER, all of my guests run perfectly.

To test if this is your problem try passing the command line option -graphicssystem raster to the VirtualBox application. This will override the graphics system for VirtualBox. Good Luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.