Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A teacher at our high school contacted me, saying that every time she presses the E key it prints out a euro sign. It's not the language settings, I already tried that. It happens in all programs, and regardless of who's logged in. Could a student have remapped the key when she wasn't looking?

share|improve this question
    
What windows ? In just some software or in every ? More info would be good. –  ldigas Nov 12 '09 at 21:11
    
Windows XP. Everything. Regaurdless of who'a logged in. –  Nathan Lawrence Nov 12 '09 at 21:21
    
Sorry. Who's logged in. –  Nathan Lawrence Nov 12 '09 at 21:22
    
So why not swap out the keyboard to test of that's been rigged? –  random Nov 13 '09 at 5:36
    
Did you meanwhile try restarting? –  Arjan Nov 13 '09 at 7:59

7 Answers 7

Sometimes modifier keys like Alt, Ctrl or the Windows key get "stuck". I didn't quite work out the why but sometimes it happens, as if the OS just doesn't see the key-up event.

Anyway, the usual way to get rid of that is simply by pressing all modifier keys once, so just hit Alt, Ctrl and AltGr and the issue should go away.

It's especially annoying with the Windows key, though, as this causes programs to start on every second keypress (E for Explorer for example). On a slow machine that can be frustrating.

share|improve this answer
1  
If the modifier keys were stuck, then other keys also were producing their alternatives (or ouput nothing if there is no alternative/special function). –  Martin Nov 13 '09 at 8:30
    
While this is true, it does not match the above scenario. What all we answers need is more information about the nationality of this keyboard and its user. –  Guy Thomas Nov 13 '09 at 8:32
    
Actually the OP didn't say anything about any other keys. So where do you take the idea that other keys aren't affected? We simply have no data on this so all we need is somthing that explains the specific data point we have, which is that E produces €. –  Joey Nov 13 '09 at 20:12

Your suspicions of keyboard remap can easily be verified by downloading a utility like KeyTweak which will show you all key mappings currently in effect, and can also be used to restore all defaults.

share|improve this answer

This happened to me just now, in Turkey we also have the euro key mapped under E, and accessible using altGr. I tried to keyboard tricks mentioned here to no avail. The other keys seemed to work fine. I then saw that the function lock light was lit. I pressed the FnMode key on the right corner of the key, and the problem was gone.

share|improve this answer

Just a quick note: I had this problem too, and nothing seemed to solve it. Restarting the computer didn't work, and worse, according to KeyTweak my mappings were all correct, the E key was correctly bound to letter e.

I solved this problem by unplugging my keyboard (I have a USB kb) and replugging it. Absurd, but it worked.

I'm using WinXP SP3. I write it down here so it can help someone else in the future.

Sabrina

share|improve this answer

It can be either a regional setting (have him change his region to an English-speaking one), or a font issue (make sure he's using a standard font and not Symbol or Wingdings :)). Also, does this happen in every application?

share|improve this answer
    
Regional setting: Can't happen, font issue: possible but highly inlikely and requires some malicious intent and effort. –  Joey Nov 13 '09 at 7:53

Students, female teacher, E key = euro. I smell a rat. Especially as the normal combination is Alt Gr (right alt) and 4.

share|improve this answer
    
i think Czech keyboard layout is using AltGr + E –  Molly7244 Nov 12 '09 at 23:13
    
I'm sure AltGr+E used to be the shortcut key when Euro first came along (so WIn 95 / 98 days). Possibly still the case for some layouts and keyboards. Is it possible she has a stuck AltGr key? –  AdamV Nov 13 '09 at 1:15
1  
This is layout-specific. The German keyboard layout has it on AltGr+E as well, as do most European layouts, I think. I am using US International here and there it's AltGr+5. On Apple's keyboard it's totally different as well. That's not something that's standardized in any way :-) –  Joey Nov 13 '09 at 7:50

I've just has this same issue on OpenSolaris. I was typing away when suddenly (after I must have hit some weird key combination) the keyboard mapping changed "e" to print "€". After bit of testing, it seems that Right Ctrl + Alt + e returns the mapping to normal - not sure if this will be the same on Windows on not.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.