Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

All the terminal programms like Terminal, xterm and Guake-Terminal close after one second. The error happens after i changed the /.bashrc with exec somescript.py. Can you tell me how to solve this problem?

EDIT: I solved the problem with Strg + Alt + F2 and then changing the bashrc again.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

It's doing what you told it to, executing the script rather than continuing with the shell. You can solve the problem by undoing the change you made. (From single-user mode if you don't have ssh access or some other way in.)

Here's a tip: If you make changes to the login process, login shell, or login scripts, do not log out until you have confirmed that you can log back in. If you change anything that could conceivably prevent a system administrator from logging in, make sure you keep a logged in system administrator console until you confirm the changes work and that a system administrator can still log in.

share|improve this answer
    
Hi David, but how to enter the single-user mode? –  kame Jan 6 at 5:11
    
It depends what boot manager you're using. Punch "linux single user" into your favorite search engine. If you know it, add the name of your boot manager. –  David Schwartz Jan 6 at 5:43
    
i solved the problem with Strg + Alt + F2 and then changing the bashrc again. –  kame Jan 6 at 5:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.