Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm looking for a way to disable the possibility of changing the wallpaper on a Linux Mint 12 install on a public computer. I searched the internet, but I didn't get any straightforward answer so far.

share|improve this question

1 Answer 1

This method worked in ubuntu. I've read Mint comes from ubuntu so I hope this works! (And I really hope it does, because it took me some investigating!)

You can use dconf. Dconf looks for the profile user to load its configurations, so you have to create it if it isn't already (it wasn't for me). You can also export a variable to set another default user but that'll be more hassle.

Go to /etc/dconf/profile and create a text file named user. This might require administrator rights. The easiest way to do it is to open up a terminal (ctrl-alt-t) and writing this:

sudo gedit /etc/dconf/profile/user

Feel free to replace gedit by your favourite text editor (hint: vim) When editing that file you should add the following line:

system-db:local

This tells dconf to open up the database local and load the settings for the system. You can name it poopman instead of local if you wish (if you do the same in the next steps).

Now let's create the db file. This goes in /etc/dconf/

First create the folder local.d and a subfolder locks

sudo mkdir -p local.d/locks

Inside, create the keyfile 00_wallpaper and edit it. I believe you can name it chestnut if you wish but that's not going to be too descriptive.

sudo gedit /etc/dconf/db/local.d/locks/00_wallpaper

Add the following inside:

# prevent changes to the wallpaper
/org/gnome/desktop/background/picture-uri

Last step is to update system databases:

sudo dconf update

You should now see a file named local in /etc/dconf/db/

And voilà, no need to relog. Try to change your wallpaper right now and you'll see it's not possible! To revert these changes just remove or comment the lock and run dconf update again.

Check this for more information: https://wiki.gnome.org/Projects/dconf/SystemAdministrators

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.