Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently moved away from Gnome because my virtual machine simply could not handle the load. The VM is running Debian and XFCE 4.10.1 (I've tried out LXDE before, too). The one thing that bites me is that I cannot see the active tab, the only visible difference is a one-pixel wide bar that is slightly lighter, almost impossible to see without a magnifier. Other terminal emulators seem to exhibit the same problem. I've searched with Google and have already tried out many different things:

  • changed the active theme using <Settings>/<Appearance>.
  • created .config/gtk-2.0/gtk.css/.config/gtk-3.0/gtk.css and added values there.
  • modified theme files.
  • modified .gtkrc.

Nothing has worked so far. So, how can I make it that the active TAB is discernible from the other tabs? A different color would be best, but anything reasonable would do.

share|improve this question

2 Answers 2

I have the same problem since I upgraded from antix 13.1 to antix 13.2 (based on debian). My tweaked config resulted in indistinguishable active and inactive tabs. But the default account shows clear distinction between the two.

So I ldd /usr/bin/roxterm | grep gtk and found out that the version of gtk that my roxterm uses is libgtk-3.so.0 .

I found that the default account has this file~/.config/gtk-3.0/settings.ini , which my tweaked account doesn't. So I copied it and now roxterm has distinguishable tabs.

It has this crucial line: gtk-theme-name=MediterraneanWhite

You can also find /usr/share/themes/ -iname gtk-3.0 and try different themes such as Adwaita or HighContrast or whatever you find in your /usr/share/themes/.

2014-09-08 update: Editing ~/.config/gtk-3.0/gtk.css gives you a finer way of changing the color of the active tab: http://harts.net/reece/2013/02/26/highlighting-the-active-tab-in-gnome-terminal/

share|improve this answer
    
+1 sounds promising -- unfortunately I can't verify if that works for me since I have switched to terminator out of frustration. If enough people upvote here and verify that I can accept your answer :) –  hochl May 18 at 10:44

You seem to be editing the wrong files:

  • .gtkrc is used only by Gtk 1.
  • .config/gtk-3.0/gtk.css is used only by Gtk 3.
  • .config/gtk-2.0/gtk.css is not used by anything, because Gtk 2 used gtkrc-format themes, not CSS.

Gtk 2, which Xfce uses, keeps its settings in .gtkrc-2.0 – and for themes, in <themename>/gtk-2.0/gtkrc.

You could try a theme like Clearlooks, which has a fairly thick blue highlight for "active" tabs. If that is not enough, you could even copy its gtkrc to ~/.themes/Clearlooks/gtk-2.0/gtkrc, find the part that looks like this...

style "notebook_bg" {
    bg[NORMAL]        = shade (1.02, @bg_color)
}

...and change the @bg_color to @selected_bg_color, making the whole active tab blue. I have tested this just now.

Side note: It is a good idea to symlink either ~/.themes to ~/.local/share/themes or vice versa, since different Gtk versions use different paths.

share|improve this answer
    
Interesting results -- I made the changes as proposed, this time testing with LXDE. If I start <Preferences>/<Customize Look and Feel> the demo window changes color to blue for the active tab -- completely! On the other hand, roxterm is not impressed and still looks the same. Btw, the same counts for gnome-terminal :( I even changed any color value I could find to red, still roxterm looks the same (the demo applet turns completely red, so I assume the gtkrc is used by it). –  hochl Jan 8 at 21:45
    
@hochl: LXDE still uses Gtk2. Meanwhile, both gnome-terminal and roxterm are Gtk3 programs. You can use gresource list /usr/share/themes/Adwaita/gtk-3.0/gtk.gresource to see the CSS files it use, and put customizations in the .config/gtk-3.0/gtk.css file. –  grawity Jan 9 at 12:32
    
Sorry haven't worked on this problem for some days. I did use strace -f to see which files roxterm tries to open and then created a gtk.css file at that location. I confirmed that roxterm opens this file, but I have not found any setting that would influence the appearance in any way :-/ (even tried things from this post for gnome-terminal). –  hochl Jan 21 at 13:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.