Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It's the strangest thing — which is my prefatory way of saying I have no idea why this is happening, so hardly know how to search for answers. I apologize if this is something basic or if it has been asked before.

I have an "old" USB hard drive (about 4–5 years old), a Seagate 320GB FreeAgent Go. And it's been a faithful servant. I used it mainly with an even older (vintage 2005) Dell Inspiron E1505 laptop. But then I got a "new" computer, and the drive started having problems. It's not a problem of my "new" PC, since the drive has problems with any computer made in the past 5 years or so.

Plugging it into a "new" computer, the drive starts rhythmically chirping. You probably know the sound. Like a turntable squaking. It's a sound that instinctively makes me think think the drive is failing and I'd better get my data off quickly. At first it only started chirping after a few minutes, chirped for a minute, then the PC quit reading the drive. As time progressed, the duration between plugging in the drive and the PC losing it got shorter and shorter, until now it lasts only a second or two and is completely unusable. Yes, my drive is failing, I was sure.

... Only it's not. During all my panic trying to backup files, I realized that the drive, now unusable with any newer computer, still works perfectly fine with my "old" laptop. It doesn't chirp. It doesn't quit working. I can still comfortably use it for hours with that PC with no problems. Disk scans by that computer indicate there's nothing at all wrong with the drive. It also, I discovered, works perfectly fine when plugged into my new Samsung HDTV, and it has been serving movies for a year or so with no chirping and no symptoms of drive failure or any other issue.

But what the heck? Why does this drive work with those devices and then fail with anything else? I'd like to load some new movies, but now I can't plug the drive into anything. My conjecture is that it has something to do with the voltage of the USB connection — but aren't these things supposed to be a universal standard?

share|improve this question
since the drive has problems with any computer made in the past 5 years or so. Define “any computer”. Did you experience this on multiple new systems? How does the drive physically sit when plugged into the old laptop or TV as compared to the new system, is it horizontal, vertical, upside down, at an angle? – Synetech Jan 7 '14 at 16:21
It has done this on at least four or five different PCs: my new netbook, an ASUS EeePC (now about two years old), a MacBook (also about two years old), several other various PCs running Windows XP, Windows 7, Windows 8, Ubuntu, 32-bit and 64-bit, with recent AMD-based motherboards. It seems independent of operating system and the only thing the hardware has in common is that it is "new." – LonelyPilgrim Jan 7 '14 at 16:43
And what about the physical orientation of the drive? For example, does it sit vertically when plugged into the old laptop or TV but sit flat when plugged into the other systems? – Synetech Jan 7 '14 at 16:44
No, physical orientation doesn't matter. I have tried all sorts of positions with the PCs, and it likewise doesn't matter how I position it with the TV. – LonelyPilgrim Jan 7 '14 at 16:45
People are throwing around random ideas below, so you should probably address them before they continue. What is the file-system on the drive and what is the OS of the old laptop? – Synetech Jan 7 '14 at 16:48

Your drive pulls its power from the computer. Some computer's ports will deliver more than the standard 0.5A, and your XP box could be one of them. If you can find a USB "Y" cable which has one female and two male fittings, then plug your drive's USB cable into that, the combination will provide 1.0A. If the Win8 box is not delivering enough power, that could solve it.

share|improve this answer
That sounds very promising. I had a cable like that at one time but I couldn't find it. I ordered another one. I'll let you know if it helps. – LonelyPilgrim Jan 7 '14 at 19:44
Try a completely different cable - preferably shorter. That may work. – JohnnyVegas Apr 23 '14 at 18:53

Some Western Digital drives can have issues when using them on Windows 7, but be fine on Windows XP. The fix is to do a firmware update on the drive. Since this is a Seagate, you'll have to check with them for availability of newer firmware for the update.

You might have a similar issue, basically, back up the data on the drive, update the firmware, wipe the drive and reformat.

share|improve this answer
That's a good idea, but I checked on the Seagate website and there is no firmware upgrade for this model. – LonelyPilgrim Jan 7 '14 at 19:44
Was worth a shot checking, my drive was a WinXP only device till I bit the bullet on the WD Passport firmware upgrade, and that was the cure there. Some of these software/OS interactions can get a little weird. – Fiasco Labs Jan 7 '14 at 23:41

I know this is a really old question, but I wanted to throw my answer out there to help anyone who comes across this issue. I had a similar problem with an IDE 120GB hard drive from 2002 that was stored in an old USB1/Firewire enclosure. When I plugged it in, Windows would try to add the device and fail. It would show the "USB Mass Storage Device" in Device manager with the yellow exclamation icon. I tried many solutions posted here and elsewhere before I figured it out.

I opened the drive up and checked it for damage, and that's when I noticed this old drive still used jumpers. It was jumpered as a slave, which apparently older versions of Windows accepted just fine. Windows 7 expects it to be jumpered as a master or single drive, though. I reset the jumper to master mode, plugged everything else back in as it was, and plugged the drive into my new PC. It worked like a charm right away.

share|improve this answer

It's possible that it's the file system. If you can copy all the files to a backup folder on your new computer, ensure they're properly copied and then you could try formatting the external drive using the NTFS file system (assuming it's a Windows computer).

It's possible that if it's the old FAT file system that newer operating systems may not like reading it, especially if the allocation sizes are non standard.

share|improve this answer
The drive is NTFS-formatted, so I don't think that's it, but thanks. – LonelyPilgrim Jan 7 '14 at 16:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.