Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I first started testing windows 7 RTM, I created a separate partition for it. That left me with a vista partition (carrying all my personal files and stuff), and a windows 7 partition. When 7 came out, I ended up doing a clean install on the second partition (the one that had the RTM version) instead of upgrading the vista installation.

Now I have all my files stored in a large partition, and windows 7 installed on a smaller partition, which is perfect. Problem is: vista is still installed on the large partition, and it takes up quite a lot of space. When I boot into 7 and try to remove the system files from the vista partition, I click through the usual UAC prompt, but then I get a notification saying: "You need permissions from XXX to perform this action." Where XXX is the name I had given to the PC in the vista installation. And my only options are "Try Again" or "Cancel".

Booting a Ubuntu live CD might do, but I was hoping for a way to do it directly from Seven, I'm just that lazy. =P

So: How can I erase windows system files that are on a different partition (and belong to another installation)?

Backing up my Personal files and formating the vista partition would take way too long, there are quite a lot of files.

Wow, that was a long question. Thanks to those who read all of it.

UPDATE:It seems that taking ownership of the files should solve the problem, but my "Take Ownership" right-click-menu option isn't reaching inside the folders. That would force me to take ownership of the files one by one. Does anyone know the command to take ownership of everything inside a folder?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You need to "take ownership" of the files. How to Geek method. Or use Ultimate Windows Tweaker to add this facility and a bunch of other stuff.

share|improve this answer
    
There is a "Take ownership" option in the right-click menu, and I believe it comes from UltWinTweaker. I tried Using it on the Program files(x86) and it seemed to work, but I still get the same error when trying to erase the folder. Manually taking ownership and then deleting each file inside it does work. Wonder why... –  Bruce Connor Nov 13 '09 at 2:46
    
I'm guessing the command is probably missing an option to reach inside the folders, know what it is? –  Bruce Connor Nov 13 '09 at 2:49
    
You are looking for a check box which says 'Replace all existing ...' –  Guy Thomas Nov 13 '09 at 8:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.