Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded the openssl version on AIXX 6.1 server.

The install went fine.

But now I'm unable to start new ssh sessions from puty to the server and I'm getting the error "Connection Refused".

But I have one putty terminal open which is active.

I tried the command startsrc -s sshd and it returns a new pid but I'm not able to start new sessions.

I tried the following command too and it gives the foll error:

root:stud -> $ /usr/sbin/sshd -de
exec(): 0509-036 Cannot load program /usr/sbin/sshd because of the following errors:
        0509-150   Dependent module /opt/freeware/lib/libcrypto.a(libcrypto.so.0) could not be loaded.
        0509-152   Member libcrypto.so.0 is not found in archive

And sshd is inoperative.

root:stud -> $  lssrc -s sshd
Subsystem         Group            PID          Status
 sshd             ssh                           inoperative

How can I resolve this issue.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

With the installation of the new version of openssl, you must have a new version of libcrypto.so somewhere on your system. What you need to do is to locate this new version of libcrypto,

  find / -type f -name 'libcrypto*' -print 

and, once you have found it, create a link to this new library with the name libcrypto.a:

  ln -s /path/to/libcrypto_new  /opt/freeware/lib/libcrypto.a

Edit:

Did you search for libcrypto* or for libcrypto.a? My version of sshd, I can check this with the command

   ldd /usr/sbin/sshd 

depends on libcrypto.so.1.0.0, libcrypto.so.1, lib5kcrypto.so.3. You should do the same check, and see which of the necessary libraries are available on your system. If you can find newer versions of the same libraries, you may try to do as I suggested above, i.e. substitute the old versions of the library with a link to the new ones, hoping that the two sets are compatible.

If they are not, or you do not find any obvious replacement, you may wish to recompile sshd from source, or to re-install it. I cannot see any other solution.

share|improve this answer
    
I see 2 entries /usr/lib/libcrypto.a and /usr/opt/freeware/lib/libcrypto.a when I execute the above command but when I see the file creation time they are very old and were not created today when I installed the new openssl package. What do you recommend. –  Dark Matter Jan 8 at 12:13
    
@DarkMatter (astronomer or particle physicist?) Please see the edit to my answer. –  MariusMatutiae Jan 8 at 13:13
    
I tried few options and nothing worked and finally I re-installed openssh and openssl and everything works now. Thanks for your help. –  Dark Matter Jan 8 at 14:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.