Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a database backup located in my Windows 7 Documents folder (C:\Users\Aaron\Documents...), and I'm trying to restore it using SQL Server Management Studio. However, the program is unable to access anything within the Users\Aaron directory using its non-standard file selection dialog, even when run as an Administrator.

I'm brand new to Windows 7, is there some sort of security setting that I need to trigger to give programs access to these files?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Try giving the "Network Service" permissions on the folder. Worked for me.

share|improve this answer
Could you explain how you discovered that those permissions were needed? –  Tom Wijsman Dec 5 '11 at 13:46
This page on sqlservercentral. However I didn't seem to have the security group they were talking about so I just added the network service account itself. As I added it to each sub directory SSMS could drill one level further into my user directory. (p.s. not sure what the security implications of doing this are..) –  Mike Walsh Dec 6 '11 at 1:05
This worked for me (Win Server 2008 & SQL Server 2008); but I also fear of the security implications of this. There were five different SQL Server groups; and none of them none of them allowed Management Studio to access the directory. The Microsoft Docs suggest that you don't change the "run as" account away from Network Service. –  Reboog711 Oct 8 '14 at 13:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.