Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question got kicked off of stackoverflow, and they suggested I might have better luck here.

I'm trying to learn Ruby on Rails and fighting with the environment is proving to be a challenge.

I’m running Ubuntu LTS on Windows 8.1 under Hyper-V, and I’m sort of confused about some of the things I’m seeing. I’m new to Ubuntu and Hyper-V, so understanding how they interact with each other has been interesting.

When I fire up Hyper-V Manager and connect normally, everything works fine, though the window is small and I wanted better use of screen real estate. I did some hunting around and discovered I can connect via Remote Desktop. So I installed xrdp in Ubuntu, ran ifconfig to find out the IP address of the Ubuntu session, and was able to connect via mstsc and get a full screen desktop. Great.

Except, the session I get via RDP (which I will refer to as the “RDP window”) is ‘different’ from the session I get when I connect from Hyper-V (which I will refer to as the “Connect window”).

1) In the RDP window, after I log in, my full name does not appear on the top bar like it does in the Connect window, though when I type “whoami” into Terminal in both windows, I get the same response (“robert”).

2) When I type ‘ifconfig’ in the Connect window, it works fine. When I type ‘ifconfig’ into Terminal in the RDP window, I get the following message:

Command 'ifconfig' is available in '/sbin/ifconfig' The command could not be located because '/sbin' is not included in the PATH environment variable. This is most likely caused by the lack of administrative privileges associated with your user account.

ifconfig: command not found

So in the RDP window, I’m not an administrator, but in the Connect window, I am, despite being logged into the same account. I have to do 'sudo ifconfig' in the RDP window.

3) I installed the Chrome browser, which works ok, except when I run Chrome in the RDP window, the Chrome browser window appears in the Connect window. Firefox does not exhibit this behavior, but if I run Firefox in the RDP window, I get an error when I try to run it in the Connect window. If I log out of the Connect window, I can get Chrome to start in the RDP window.

4) I’m using Ubuntu One to back up my files. I have folder sync turned on. It doesn’t sync in the RDP window. I have to log into the Connect window in order to get the files to sync.

5) I get popups in the RDP window about unlocking my key ring that do not appear in the Connect window.

I can make some of these problems go away by simply not logging into the Connect window, though since I need Ubuntu’s IP address in order to connect via RDP when I’m dealing with a strange DHCP server, this isn’t always convenient. Chrome starts normally when it has no Connect window to start up in, though Ubuntu One still doesn’t sync. I’m sure there are other differences that I just haven’t noticed yet.

Can someone explain what’s going on here? I’m sure this is pretty obvious, but I’m not sure how to describe this situation in such a way as to do a Google search to figure out the problem. Ideally, I'd like to RDP window to behave the same way as the Connect window, but I'm not sure how to get there from here.

Thanks in advance.

-Rob

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.