Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is a follow up to FTP BAT file - Windows Scheduled Task.

I copied the FTP script, but I can't transfer the files to my local computer.

All I get is this (server address omitted):

331 Password required for ftpdemo.

230 User ftpdemo logged in.
ftp> lcd C:\Temp\Test
Local directory now C:\Temp\Test.
ftp> mget ErrorLog\*.*
200 Type set to A.
mget LogViewer.asp? quit
ftp>

Here's the actual script:

open ftp.myserver.com
ftpdemo
pass
lcd C:\Temp\Test
mget ErrorLog\*.*
quit

What do I need to fix?

UPDATE:

used PROMPT, now it loops through all the files, but keeps saying the following:

200 port command successful
550 "file_name_here": no such file

and same goes for every file in the directory ... it lists all the files, so they ARE there, I have no idea what's wrong. Also, I use the same account that I use for GUI ftp, and permissions should not be an issue.

Any ideas?

UPDATE 2:

here's how i got it to work (thanks to dave lozinski's site):

open ftp.myserver.com
ftpdemo
pass
lcd C:\Temp\Test
cd /ErrorLog
prompt
mget *.*
quit

basically I just had to change the directory on the server.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Before the mget command add a line that says

prompt
share|improve this answer
    
now this goes thru all files on remote folder, but keeps saying "port command successful. no such file" ... all files are there though ... any ideas? –  roman m Nov 13 '09 at 8:45
    
didn't solve the issue but helped me get starter, thanx –  roman m Nov 13 '09 at 9:15
    
did you fix why the files weren't coming down? –  Stewart Robinson Nov 13 '09 at 16:36
add comment

Perhaps ftp -i will solve the problem.

This parameter turns off interactive prompting during multiple file transfers, which is the prompt that I see in the post.

share|improve this answer
    
same results ... loops thru all the files in the folder, and keeps saying "no such file" but all the files are there ... i use the same credentials as i use for GUI ftp access, so permissions should not be the issue ... any ideas? –  roman m Nov 13 '09 at 8:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.