Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop running wampserver. Within the laptop I am able to browse by going to http://192.168.1.104/ in my browser. I'm trying to visit these same pages on my mobile phone that is on the same wifi network, but when I go to http://192.168.1.104/ on my mobile browser I get 403.

I checked the access logs and it's hitting apache, but for some reason it's shown as requesting from a different ip http://192.168.1.127/.

Any idea what I've missed? Apache is already listening to port 80. I am using a Linksys ES4200 router for my LAN.

Thanks!


UPDATE

This is what I see in my access logs when I try accessing first from the host laptop itself, and then from 2 different devices.

192.168.1.104 - - [13/Jan/2014:11:43:38 -0500] "GET / HTTP/1.1" 200 9277
192.168.1.127 - - [13/Jan/2014:12:28:30 -0500] "GET / HTTP/1.1" 403 223
192.168.1.133 - - [13/Jan/2014:12:37:47 -0500] "GET / HTTP/1.1" 403 223

I've confirmed that the last 2 ip addresses correspond to the devices I'm testing from.

.htaccess:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /CENSORED/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /CENSORED/blog/index.php [L]
</IfModule>

# END WordPress

httpd.conf

ServerRoot "c:/wamp/bin/apache/apache2.4.2"

Listen 80

LoadModule access_compat_module modules/mod_access_compat.so
LoadModule actions_module modules/mod_actions.so
LoadModule alias_module modules/mod_alias.so
LoadModule allowmethods_module modules/mod_allowmethods.so
LoadModule asis_module modules/mod_asis.so
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authz_core_module modules/mod_authz_core.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule dir_module modules/mod_dir.so
LoadModule env_module modules/mod_env.so
LoadModule include_module modules/mod_include.so
LoadModule isapi_module modules/mod_isapi.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule mime_module modules/mod_mime.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule php5_module "c:/wamp/bin/php/php5.4.3/php5apache2_4.dll"

<IfModule unixd_module>
  User daemon
  Group daemon
</IfModule>

ServerAdmin  admin@localhost
ServerName localhost:80

<Directory />
    AllowOverride none
    Require all denied
</Directory>

DocumentRoot "d:/NetBeans Projects/"
<Directory "d:/NetBeans Projects/">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require local
</Directory>

<IfModule dir_module>
    DirectoryIndex index.php index.php3 index.html index.htm
</IfModule>

<Files ".ht*">
    Require all denied
</Files>

ErrorLog "c:/wamp/logs/apache_error.log"

LogLevel warn

<IfModule log_config_module>
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common

    <IfModule logio_module>
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
    </IfModule>

    CustomLog "c:/wamp/logs/access.log" common
</IfModule>

<IfModule alias_module>
    ScriptAlias /cgi-bin/ "cgi-bin/"
</IfModule>

<IfModule cgid_module>
</IfModule>

<Directory "cgi-bin">
    AllowOverride None
    Options None
    Require all granted
</Directory>

<IfModule mime_module>
    TypesConfig conf/mime.types

    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php .php3
</IfModule>


<IfModule proxy_html_module>
  Include conf/extra/proxy-html.conf
</IfModule>

<IfModule ssl_module>
  SSLRandomSeed startup builtin
  SSLRandomSeed connect builtin
</IfModule>

Include "c:/wamp/alias/*"
share|improve this question
    
I would suggest checking it from another computer on the network, if you find the same issue please paste your .htaccess file and the httpd.conf somewhere and put up the links here. –  Gaurav Joseph Jan 10 at 6:12
    
Gaurav, what's a good place to paste logs? –  Anson Kao Jan 13 at 18:00

1 Answer 1

up vote 2 down vote accepted

Are you sure its showing as requesting FROM 192.168.1.127 rather then the machine making the request is 192.168.1.127 ?

A 403 error implies the page is being reached but the server is configured not to allow viewing of the resource from the requesting system.

Updated Answer:

I don't know where your Wordpress config is, but this draws attention:

DocumentRoot "d:/NetBeans Projects/"
<Directory "d:/NetBeans Projects/">
    Options Indexes FollowSymLinks
    AllowOverride All
    **Require local**
</Directory>

Require local implies it will only match against IP's associated with the server. If Wordpress is being fed from a subdirectory of this then that would explain your problem.

If thats not it, look for something similar in the config files in "c:/wamp/alias/*"

share|improve this answer
    
You were right, 192.168.1.127 is the ip-address of my requesting phone. I tried with another device, same result. I guess the culprit must be somewhere in my apache config, I've updated the qeustion above –  Anson Kao Jan 13 at 17:48
1  
The problem could well exist in your apache config - but if so, it does not exist in the code snipped you posted. It is, however, also possible that Wordpress is returning this error - this would probably only be the case if you have an additional security plugin though. (Looking a the source code there is provision for WP to provide back a 403 error in some cases). What is the exact text associated with the error on the client side ? This could help track down whats causing it, as it can provide clues ? –  davidgo Jan 13 at 18:13
    
Added the httpd.conf file. It's the generic Apache 403 page, not a WP 403 page. –  Anson Kao Jan 13 at 18:19
1  
See expanded answer. –  davidgo Jan 13 at 22:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.