Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried to install - actually, upgrade from 7100 RC - the Windows 7 RTM. Everything went fine, installation completed, and logon screen appeared - I entered my logon info (domain credentials)... and when I pressed Enter it said:

  • logging off
  • shutting down
  • and then rebooted.

After reboot, there was no Windows 7 boot menu and no boot menu at all - it jumped right into old Windows XP installation that I abandoned when installed Windows 7 RC.

Note that XP is installed on C:, while W7 is on E:. This is how boot.ini looks like now:

;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT

Boot.ini.saved has the same content.

Yes this blog states that "“in-place” (or direct) upgrades from the Windows 7 RC to RTM will not be supported" but RTM installer actually allows to performs this. UPDATE: yes, I did change "min supported version" from 7322 (or whatever) to 7000 in the installation .ini file. Thus, I do not blame MS or whatever. Just trying to find a solution.

So, is there any way to resolve this except clean Windows 7 installation? Is this a known issue?

UPDATE: here's bcdedit (from W7 on drive E:) output: - is there a way to use it to switch W7 on?

E:\Windows\System32>bcdedit

Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=C:
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {default}
resumeobject            {830cc0c5-6cbe-11de-9e38-d784ddd4a91e}
displayorder            {ntldr}
                        {default}
toolsdisplayorder       {memdiag}
timeout                 3

Windows Legacy OS Loader
------------------------
identifier              {ntldr}
device                  partition=C:
path                    \ntldr
description             Earlier Version of Windows

Windows Boot Loader
-------------------
identifier              {default}
device                  partition=E:
path                    \Windows\system32\winload.exe
description             Windows 7
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {830cc0c9-6cbe-11de-9e38-d784ddd4a91e}
recoveryenabled         Yes
osdevice                partition=E:
systemroot              \Windows
resumeobject            {830cc0c5-6cbe-11de-9e38-d784ddd4a91e}
nx                      OptIn
share|improve this question

1 Answer 1

up vote 0 down vote accepted

OK, I've found the answer on one of the forums (I've found it while in XP and now I'm in W7 so don't remember the link): got EasyBCD, reinstalled Vista bootloader, and I'm in Windows 7 now.

Don't know what happened, though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.