Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some programs don't display output of some children processes. As you can see is a screenshot,

I tried to run php --version in three console utilities: Git Bash (MinGw), native Windows 8 command line and Cygwin terminal.

The first two programs return information about version of PHP, but Cygwin does not print any output. However, Cygwin is not the only program that doesn't print console output of children processes. For example, qmake (the part of Qt Framework) also returns nothing in Cygwin when running qmake -query. As a consequence, I cannot use Qt Creator on my PC, because Qt Creator cannot parse output from qmake.

Any ideas how to solve this problem? Currently I use Windows 8 x64, but this problem also took place when I had Windows 7 x64 installed on my PC.

share|improve this question
Did you install PHP and Qmake via the Cygwin installer? I didn't know PHP was provided by Cygwin... – DanteTheEgregore Jan 10 '14 at 21:24
No, these programs were installed using their native installers, but some native console Windows utilites like ipconfig, tracert, etc work fine in Cygwin. So I thought that Cygwin hasn't problems with running Windows applications in general, but only some applications work in Cygwin incorrectly. – Serg Jan 11 '14 at 16:06

2 Answers 2

up vote 0 down vote accepted

You are mixing terms!

First screenshot is the same as second - it is a standard Windows console.

Third screenshot, in fact, is mintty emulator, but not a real console. See "min" in its name? Huge amount of applications can't be run in mintty at all!

I believe, the solution is to use proper console. Also, you may try ConEmu as advanced Windows terminal, it is "all propose and full-featured" (I'm the author).

As for QT creator... Try to use ProcessMonitor to find the problem. Yes, this is not quick and easy, but you may try. If it is working on the another PC you have, you may compare your logs. Also, may be some third-party tool install global hooks, which interferes normal behavior of piping. May be something else... Viruses or antiviruses, no?

share|improve this answer
Thanks for advice, I will try ConEmu. Also I just tried to write a Hello World application using Visual C++ 2012 and Cygwin didn't printed its output again. So Cygwin actually doesn't works good with some applications. However, the situation with Qt Creator still remains unclear: why Qt Creator cannot work with qmake.exe? It seems that Qt Creator tries to read a configuration from qmake, but receives an empty response. I suspect that the reason of this issue must be similar. Does Qt Creator use some tools for emulation of Unix? – Serg Jan 11 '14 at 16:28
Answer updated. Try ProcessMonitor? – Maximus Jan 11 '14 at 17:47
I didn't found any problems using ProcessMonitor. Also I tried diffenrent installation types of Qt like online/offline, x86/x64, and finally I found that the problem was in installation directory. Earlier I installed Qt to partition D and it didn't worked. Now I installed it to partition C and everything worked fine. Seems that this bug is related to Qt, but not to the system in general. In any case, thanks for help, the problem is solved! – Serg Jan 12 '14 at 14:54

As user Maximus suggested here before, the reason was Antivirus software. After I added Cygwin and Qt to exceptions list, both programs began to work properly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.