Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My cable modem uses IPv6 and so does my LAN. I want to connect my laptop to the hamachi service. However, the laptop tries to connect via IPv4 and this attempt fails.

The network configuration of my laptop looks like this

wlan0     Link encap:Ethernet  HWaddr 00:1e:64:47:00:cc  
          inet addr:192.168.0.13  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21e:64ff:fe47:cc/64 Scope:Link
          inet6 addr: 2a02:908:f621:8500:21e:64ff:fe47:cc/64 Scope:Global
          inet6 addr: 2a02:908:f621:8500:5c4e:d721:be73:ffb3/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:616810 errors:0 dropped:0 overruns:0 frame:0
          TX packets:291628 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:919920604 (919.9 MB)  TX bytes:32471751 (32.4 MB)

ham0      Link encap:Ethernet  HWaddr 7a:79:19:5b:cc:3c  
          inet addr:25.91.204.60  Bcast:25.255.255.255  Mask:255.0.0.0
          inet6 addr: 2620:9b::195b:cc3c/96 Scope:Global
          inet6 addr: fe80::7879:19ff:fe5b:cc3c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1404  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:113 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500 
          RX bytes:0 (0.0 B)  TX bytes:22370 (22.3 KB)

and according to the config file IPv6 is enabled

$ cat /var/lib/logmein-hamachi/h2-engine.ini
Bits                 20129066
Bits2                0001008c
Conn.Last            0
CreateAcc            0
DegradeKey           
HostSent             
IPv6Cfg              2
LicExpiry            1387220302
LicType              0
LmiEmail             **************
NetState             183-243-613, 1, 1
NetState             185-627-460, 1, 1
Nickname             **************
Reconnect            1
RetryDisc            8
VIP4Addr             25.91.204.60
VIP4Mask             255.0.0.0

However, the service is resolved to a IPv4 address and connection to this address takes very long and then fails (probably because IPv4 is used):

01.11 12:21:39.157 sys: go_online, reconnect 1
01.11 12:21:39.157 ses: selected (h-app03-03.hamachi.cc, 5805)
01.11 12:21:39.157 ses: selected 01 connection type
01.11 12:21:39.269 ses: resolving h-app03-03.hamachi.cc ..
01.11 12:21:39.482 ses: connecting to 212.118.234.69:12975 ..
01.11 12:23:46.671 ses: connection is established
01.11 12:23:46.783 ses: control connection is bound to 192.168.0.13
01.11 12:23:46.783 ses: << msg_helo ..
01.11 12:23:46.872 ses: io error, send, 110
01.11 12:23:46.873 ses: error 3, retryable yes
01.11 12:23:46.873 ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 10 ..
01.11 12:23:47.193 ses: reconnect delay: 389 sec

I already tried sudo hamachi set-ip-mode ipv6 but this does not change the fact that IPv4 is used.

Is there any way to make Hamachi work over IPv6? Any help would be appreciated!

PS: I use the latest version of hamachi: 2.1.0.119

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.