Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have firefox that crashes every so often on my Ubuntu machine. I can't seem to kill the process when this happens. The process' name is /usr/lib/firefox/firefox

I've tried:

pkill -f firefox
pkill -9 firefox
kill <id>

I tried killing it in htop. I saw there were 3 sub processes there. I could kill two of them but not the plugin-container process.

I ran ps auxww and the process does not show a U to indicate that it's stuck. It does show a D however.

share|improve this question
1  
Please show us the output of ps aux | grep firefox. –  terdon Jan 11 at 12:46

1 Answer 1

type

ps aux | grep firefox

note the JOB ID type the following line

kill 4347

4347 is example the job id

i think it may help :)

share|improve this answer
    
He's already done that, he tried kill, pkill and pkill -9 and none of them worked. –  terdon Jan 11 at 21:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.