Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed the following dependencies before trying to compile Vim 7.4 from source on Fedora 20 (Default Gnome). I've removed the vim-enhanced package via yum before proceeding:

yum install ncurses-libs gnome-libs-devel libgnomeui-devel
    gtk2-devel libbonoboui-devel libX11-devel libXpm-devel
    libXt-devel python-devel ruby-devel cairo-devel

However, when I try to do something like:

./configure --with-features=huge --enable-rubyinterp
            --enable-python3interp --enable-gui=gnome2
            --enable-cscope --prefix=/usr/local --with-x=yes | grep gui 

I get the following during the configuration step:

checking --enable-gui argument... no GUI support

I've installed all the dependencies that I know of. I've searched online, and cannot find any references to solve this problem. Is there a dependency that I'm missing?

share|improve this question
    
I don't have the answer to your question, but unless you have a particular reason for not letting Vim auto-configure the GUI support, I would leave out the --enable-gui=gnome2 option. Also, the default prefix is /usr/local, so you don't need that, and with --with-features=huge, you don't need --with-x, either. –  garyjohn Jan 12 at 9:05
    
Actually, I tried doing that (even --enable-gui=auto). I added things like --with-x as a desperate attempt to get it to work. –  AgilE Jan 12 at 16:45
    
Did you check the auto/config.log file? –  Heptite Jan 12 at 18:36
    
Yes, I did. I didn't find anything useful there. However, I just re-downloaded the mercurial repository and this time, it worked. I might have added new dependencies in between, but it only started working on a fresh repo checkout. –  AgilE Jan 13 at 3:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.