Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 SP1 machine with

  • C: 120GB SSD
  • D: 2TB HD
  • E: 500GB HD

All disks are truecrypt encrypted with D and E being system favorite volumes. Today I booted the machine and I got the dreaded Operating System not found error. I booted into the Truecrypt Rescue CD and tried to restore the boot loader. It failed. I then decided to decrypt the system drive, which succeeded after about an hour.

I then booted the machine and I get Error Loading Operating System.

So, I boot from the Windows 7 DVD and select Repair and go to the command prompt and do the following:

X:\Sources>diskpart

DISKPART> list disk

  Disk ###  Status       Size     Free     
  --------- -----------  -------- -------
  Disk 0    Online       111 GB   0 B
  Disk 1    Online       1863 GB  1863 GB
  Disk 2    Online       465 GB   0 B

DISKPART> select disk 0

Disk 0 is now the selected disk.

DISKPART> list part

  Partition ###  Type          Size     Offset
  -------------  ------------- -------- -------
* Partition 1    Primary       111 GB   0 B

DISKPART> list volume

  Volume ###  Ltr  Label        Fs    Type        Size     Status     Info
  ----------- ---- ------------ ----- ----------- -------- ---------- -------
  Volume 0     E   GRMCULXFRER  UDF   DVD-ROM     3075 MB  Healthy
  Volume 1     C                RAW   Partition   111 GB   Healthy
  Volume 2     D                RAW   Partition   465 GB   Healthy

DISKPART>

EDIT:

I also tried Startup Repair from the System Recovery Options dialog and it found a corrupt partition table on Disk 0, but says it repaired it. When I reboot, the machine doesn't find the operating system and Startup Repair finds the partition table to be corrupt again on the next boot. Here's a screenshot

Imgurenter image description here

I'm not sure how to recover the boot sector of my SSD. Any ideas?

share|improve this question
    
It's seems like Your System MBR damaged you try Could repair the MBR it may be solve your problem, or run time select your hard-drive you want to boot from or you could repair your operating system. –  Shailesh Jan 16 at 9:06
add comment

1 Answer

up vote 0 down vote accepted

I could not solve this and ended up reinstalling Windows.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.