Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do you set up a Windows Vista Home Basic desktop (wired) and a Windows 7 Home Premium laptop (wifi) on a home network so that they can share files and the printers connected to the desktop? The Win7 laptop may also be used on other networks.

I'm going to have to set this up for my parents when I visit shortly. I currently use XP and am not really familiar with Vista or Win7 network setup.

Would it be difficult to share between the Vista and Win7 machines and and XP machine? If not, how to add that?

share|improve this question
add comment

5 Answers

up vote 1 down vote accepted

If I understand the question correctly and assuming you have a wireless router for DHCP . You right click on the My Computer and go to properties and put both systems in the same workgroup. Reboot and see if you can ping the two computers from each other.

I would also set up the two computers first connected without wireless confirming they can see each other. Then configure secure wireless

share|improve this answer
    
They have a wireless router with DHCP. Do I have to turn on file and print sharing and designate shared folders? –  foosion Nov 13 '09 at 15:21
    
Yes you will have to turn on file and print sharing Heather has a good point. I am running it on my home network with 5 Xp , 1 Vista , and 1 Win 7 computers. but all are running the Pro versions. I also have never set this up with the home versions. –  Boxdog Nov 13 '09 at 15:35
add comment

There is no problem at all about networking Vista with Win7.

On the other hand, it might be VERY hard to set up a network that includes XP with higher Windows versions.

See this thread : Vista pc hidden from XP?
where despite all the good advice, we didn't succeed in incorporating XP into the network.

That said, if all you're interested in is a manual integration, this is easy. If the XP machine doesn't show up in the Network Neighborhood, just use its IP address. Use the command "ipconfig" to find out the XP computer's IP address, for example 192.168.0.123, and enter in the address-bar of Windows Explorer of Vista/Win7 the address "\\192.168.0.123" or "\\192.168.0.123\share-name".

share|improve this answer
    
Any settings to worry about? Turn on file & print sharing? Set security if you're only home or will be using wifi in public? I use \\192.168.0.123\share-name on my home network. Glad to hear I can use it while I'm there. –  foosion Nov 13 '09 at 15:28
    
File & print sharing is prerequisite. Better check your parents' router for minimal security like WEP/WPA and setup a MAC filter. –  harrymc Nov 13 '09 at 15:38
    
The router is a Linksys WRT54GL with WPA2. I don't have much faith in MAC filtering. Any complexity to the file & print sharing settings? –  foosion Nov 13 '09 at 15:40
    
Not faith - rather adding another protection. For file & printer sharing, right-click the network card, Properties, and probably it's already checked. –  harrymc Nov 13 '09 at 16:25
    
It's so easy to circumvent MAC filtering that I don't consider it worth the effort. The marginal benefit above WPA or WPA2 is approximately zero, IMO. –  foosion Nov 13 '09 at 17:21
show 1 more comment

What version of XP? I didn't have problems setting up file sharing between Win 7/Vista and XP Pro, but I've never been able to get it to work with XP home. These were the settings I used on the Win 7 computer:

Network Disovery = ON

File and printer sharing = ON

Public folder sharing = ON

Media Sharing = Any

Password protected sharing = Either setting worked fine.

share|improve this answer
    
XP Pro SP3. The main issue is WIn 7/Vista. Networking XP is just to make things easier when I'm there. Can I set the Vista machine to not require a password and the Win7 to require a PW? The vista will always be behind a secure router, while the win7 might go out in public. –  foosion Nov 13 '09 at 15:38
    
Having the PW on network sharing turned off on my Vista box didn't work until I gave "Everyone" some sort of permissions on the shares I set up, after that the XP computers could see and modify the Vista shares. Even with the PW turned on, there is an option to remember the network password every time the share is accessed. –  Heather Nov 13 '09 at 16:25
add comment

The majority of problems in Windows XP Home come from the inability to easily change security permissions. In general, windows will attempt to first connect to a remote computer using the local credentials. When that fails (because the remote machine doesn't have that user account) it defaults to the "guest" account. By default, this account is disabled and has the "Deny access to this computer from network" security policy applied to the account. This is mainly used to "protect" the user from unauthorized access. Which in reality, doesn't keep anyone safe and just causes problems when you want to share files.

Now simple file sharing is supposed to manage all of this stuff for you, but it doesn't always work. So before you go hunting around, check out the following site, see if the steps included allow you to connect:

http://support.microsoft.com/kb/304040

http://www.practicallynetworked.com/sharing/xp/filesharing.htm

If you've done everything explained in the above links, it's time to dig into the OS utilities.

The first thing to check is your user accounts. My favorite way to check this is to Right click on "my computer" and go to "manage". Under "System tools> Local Users and Groups> Users" it should show you all users on your computer. There are two things you can try, enable the guest account, or add the user account that is used on the non-XP machine. If you create a user account that uses the same password that is used on remote machines, it should use that account instead of the guest account when connecting to your computer.

Once you have verified that your guest account is enabled, check on the security settings. Go to "Control Panel> Administrative Tools> Local Security Policy". Once in the utility, go to "Local Policy> User Rights Assignments" and find "Deny access to this computer from network". Double left click the item to modify and remove Guest. Hit OK and close out the utility. You should be able to connect to your shares from the remote machine.

I am 99% sure that you have access to both of these utilities in XP Home, my one XP Home machine was setup a few years back and I haven't messed with this recently. Though every time I setup an XP machine at all, I have to do this process.

Hope this helps

share|improve this answer
add comment

Don't forget the simplest thing overlooked in any windows xp to windows vista or 7 network is that ALL computers MUST have a password on the user accounts otherwise windows vista will not allow access to the available network shares or workgroup.

Other issues with windows xp home include a failure to correctly register new computers on a network, this can usually be resolved by opening up a command window, start->run->cmd in xp or all programs->accessories->command prompt for windows vista or 7 (**right click and select run as administrator on command prompt).

once the command window is open type;
ipconfig /flushdns press enter, then ipconfig /registerdns press enter again then restart the computer.

this will usually correct issues when opening workgroup.

other things that may help, you can usually attempt to connect to a computer by opening up my computer and typing \computername\sharename into the address bar. if it asks for a user name and password use a login and password from the computer you are connecting to that has access to those resources.

Best of luck.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.