Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have D-Link 2650 router. Some wireless and wired clients connected to it. The problem is there is no interconnection between wireless and wired devices. For instance, when I start webserver on PC connected to wired LAN, WiFi devices cannot access it (other wired devices can). However all devices are in the same subnet: 192.168.1.x. How can I connect WiFi and LAN devices to one network? Or maybe what I should know first (any information with which I can proceed)?

share|improve this question

migrated from Jan 13 '14 at 18:11

This question came from our site for system and network administrators.

Enable MultiAP Isolation option looks similar to Client Isolation. The former option is available in D-Link 2750.

share|improve this answer

We need some more info ... do you know if you have ANY connectivity at all? Not being able to browse a webserver could be caused by lots of things, not necessarily a network problem.

Can you ping one device from the other? That's the first place to start. If you can't ping, then it's not a webserver problem... your router MIGHT be configured not to allow connections between the wired and wireless domains, but that's not common. Are you running the default settings on the router?

Are you 100% certain that you're connecting the wired devices to the correct ports? (only because I've seen people get the WAN port wrong...)

share|improve this answer
Thanks. I mean, webserver is an example. Basicly: I can't ping wireless clients from wired and vise versa (but actually can ping wired <-> wired, wireles <-> wireless). I can also determine correct IP, because I see wireless clients in LAN clients list, but I can't access it (ping it) anyway. – StreetStrider Jan 13 '14 at 6:18

Check option Clients isolation in Wireless -> Basic.

If it turned ON - clients from LAN wil not access Wi-Fi clients and vice versa.

share|improve this answer
Great, there is such option, thanks. But, I found this option turned off. I've tried to set it on, reboot and try to ping device. Then I've turned it off again and do another ping. In both cases there is no access (Destination Host Unreachable). But I think this is the very option I've looked for. – StreetStrider Jan 13 '14 at 6:26
Looks like your guess is correct, but this check option is broken. I've solved my issue by updating to 1.0.17 firmware. Thanks for your tip. – StreetStrider Jun 26 '14 at 18:02

Turn off Enable MultiAP Isolation and it will solve the issue.

share|improve this answer
I don't see anything similar. Do you have the same router model like me? – StreetStrider Jun 8 '14 at 13:04
up vote 0 down vote accepted

I've had 1.0.10 firmware version in D-Link 2650(NSU). Seemes that client isolation checkbox is broken in this version. I've updated to 1.0.17 firmware (following instructions on and now have wireless and wired clients communicating each other.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.