Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to use my regular Option + letter (i.e. ł = Option + L) to input such a letter to emacs (in latex mode). How to do it? Now it is overridden by jump to next word on the left.

btw. when I open a file containing such a letters they are displayed correctly.

share|improve this question

Use Command-; (or the Options > Option Key submenu) to toggle the meaning of the actual Option key. By default it switches between “Mac OS X extended character mode” and “Emacs Meta key mode”

It seems like you have “Meta mode” active (Options > Option Key > Meta), but you probably want the “extended character mode” (Options > Option Key > Standard Mac Characters).

In Aquamacs Emacs M-l (“Meta ell”) is probably bound to the downcase-word function, which looks like “move one word to the right” if the word is already in lowercase.

share|improve this answer
    
I had the opposite problem, that is, my aquamacs suddenly started using meta for characters, and I was lost, as I couldn't do my "M-x foobar", "M-v" and "M-w", among others. Your answer was really helpful and solved my problem in seconds. Thank you! – Vivi Aug 9 '10 at 6:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .