Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I moved recently and my TP-Link TL-WR841ND v7 with DD-WRT v24-sp2 (11/21/10) std (SVN revision 15778) started to work odd.

Before:

Router was conneted to another (ISP's) router/modem. Internet connection 50 Mbps, worked as expected. (40+ Mbps by WiFi, 49+ Mbps by ethernet.)

Now:

TP-Link router is connected to different router/modem (newer model), same ISP. Internet connection 120 Mbps. With direct connection to ISP's router by RJ-45 cable internet speed is ca. 85/10 Mbps, ping 8 ms

But when I connect through TP-Link speed falls dramatically - it never excels 10 Mbps, ping is unchanged. There is no difference if I use RJ-45 (cat6) oraz WiFi (NG-Mixed, WPA2)

I tried:

  • Changing WiFi broadcast channel.
  • Using different ethernet ports in TP-Link and other RJ-45 cable between TP-Link <-> PC.
  • Setting TP-Link to connect using DHCP.
  • Cloning PC's ethernet MAC adress.
  • Restoring Factory Defaults.

No luck. Any ideas?

Regards, Peter

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Did you check if the TP-Link got a full duplex or a half duplex connection on the WAN-port with the modem.

Some providers force full-duplex with their modem and if your TP-Link is at auto negotiate this will fail miserably. Try setting the WAN-port TP-Link to full-duplex.

If the modem is at full duplex and your router at auto negotiate.
you'll get a duplex mismatch with all the troubles with it.

You can set the DD-WRT to full duplex like in the picture below:

enter image description here

share|improve this answer
    
Unfortunately I have no VLANs tab under Setup - is there any other way to force full-duplex on TP-Link? I've updated to DD-WRT v24-sp2 (03/25/13) std - build 21061 - latest compatible with WR841... –  Piotr Nawrot Jan 13 at 23:29
1  
Is your connection indeed half duplex? Can you see the duplex state in the status page? I will need to look tomorrow why that page doesn't show for you (don't have access to my DD-WRT at the moment). (And if it is i take it you can't change the duplex setting on the modem to auto.neg.?) –  Rik Jan 13 at 23:37
    
I can't change modem's settings. But diagnosis seems right - log after physically reconnecting cables: Jan 14 01:12:39 DD-WRT kern.info kernel: [ 103.680000] eth1: link down Jan 14 01:12:57 DD-WRT kern.info kernel: [ 121.680000] eth1: link up (1000Mbps/Full duplex) Jan 14 01:13:41 DD-WRT kern.info kernel: [ 165.670000] eth0: link down Jan 14 01:14:01 DD-WRT kern.info kernel: [ 185.670000] eth0: link up (10Mbps/Full duplex) Question remains - how to force eth0 to go 100Mbps? –  Piotr Nawrot Jan 14 at 0:19
    
Hey, I don't see the VLANs in my old Linksys either. But the WAN-port should be assigned to eth1, not eth0. See here. What is it in yours? If it is eth1 your logs suggest ` eth1: link up (1000Mbps/Full duplex)` which means it is at full duplex (and 1000Mbps needed for the 120Mbps). Not sure about the inner workings of DD-WRT and if eth0 is used for something. –  Rik Jan 14 at 9:19
1  
BTW. do you have a 1Gbps network card in your computer (and tested it)? (or could you test with a computer with such a network card?) Just wondering if you can get the 120Mbps your provider is offering with the proper network card. If you do get 120Mbps then it probably is best to invest in a router which can handle it (on the WAN- and LAN-side). (Yours only goes to 100Mbps max. with all the problem it faces if your modem forces a 1000Mbps-FD connection) –  Rik Jan 20 at 15:36
show 7 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.