Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I broke my file association in XP... Does anyone have any clue how to fix it? When I right click and select Open With... the application I want to use (NetBeans) to open the file is not on the list... and when I browse for it it won't let me select it (well it does but then won't add it to the list).

The way I broke it is by installing 6.7 and then uninstalling 6.5.... since then my file associations have all been broken. I even tried uninstalling NetBeans and reinstalling it again... no luck...

I even went as far as adding my own action called "OpenIt" to the file types I wanted... and that works... but only if the file/folders that contain in don't have any spaces... otherwise NetBeans throws a ".....does not exist, or is not a plain file". Thus nothing off the desktop can be opened...

Does anyone know of how I can fix this problem? Thanks.

share|improve this question
add comment

2 Answers

I too had this same problem and could never figure out what was wrong - I think I've finally worked it out.

When upgrading NetBeans (or reinstalling), not all of the entries in the Windows registry are updated. Look in your registry at:

HKEY_CLASSES_ROOT\Applications\netbeans.exe\shell\open\command

Is the path listed in the "Data" field inline with your currently installed version of NetBeans?

Mine was different: it had the path to an older version (NetBeans 6.8). When I updated this value to use my most recent install (NetBeans 7.0), all was fixed.

For good measure, I did a search of my registry for any additional "NetBeans 6.8" entries and found one other that I also updated - but I have no idea what it was for.

share|improve this answer
    
Great answer. This also works if you want to change all the netbeans file associations to a different netbeans installation. –  kjetilh Oct 19 '12 at 9:00
add comment

You could just install NetBeans 6.7 again.

share|improve this answer
    
I tried... "I even tried uninstalling NetBeans and reinstalling it again... no luck..." –  Serhiy Nov 13 '09 at 16:56
    
Does this help : wiki.netbeans.org/… –  harrymc Nov 13 '09 at 17:04
    
No not really... it appears only useful for associating the extension with various MIME types once NetBeans is already opening the file. My issue is that that windows has lost the program reference and won't open the file with NetBeans when I double click. –  Serhiy Nov 13 '09 at 21:03
    
Going into Control Panel / Folder Options / File Types, click on your file type. Use Change to assign the Netbeans binary, then Advanced / Edit to ensure that the actions involved looks like "drive:\netbeans-dir\netbeans-exe" "%1". I don't use Netbeans, but there's no way that this can't work, except if some quotes are missing. –  harrymc Nov 13 '09 at 21:24
    
harrymc you're a genious... thank you very much... I still can't Use the Change to assign the Netbeans binary to Open... but for some reason I can assign it to my custom OpenIt action... and the only issue my OpenIt action had was by default the %1 wasn't wrapped in quotes. Thank you very much, at least now I can manually put in custom associations without having the space problem. Thanks a bunch, this has been plaguing me a while now. –  Serhiy Nov 13 '09 at 21:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.