Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am looking at a Toshiba P745-S4102 laptop for a friend who says that it cannot connect to wifi. It started (I guess) this past summer and she has been slow to get around to it.

Upon getting the machine I made sure that the wifi card was on and that it was seeing networks. Everything seemed fine and I tried connecting to a wireless network but windows reported that it failed connecting to the network, however it is listed as connected but no packets have been sent/received. Ok fine. So I tried a different network that I knew was working (my Mac is connected to it). Again widows says that it failed to connect but is showing up like it did connect. I then run an ipconfig /all which doesn't show any network devices at all. Only thing is shows is host name, dns suffix, node type, ip routing disabled, wins proxy disabled.

Ok obviously it must be a driver issue. So I uninstall both the LAN and wifi drivers and reinstall them. Device manager is showing them as working fine. I try to connect again with the same issues. Re-run ipconfig /all same issue. Last resort is to do a system restore to an earlier point. This also doesn't work and shows the same symptoms.

After this I plugged in a known good network cable but even the LAN is not working. The same problems persist under safe mode.

All I can think of to do is factory reset, but if possible I would rather not. Hopefully someone out there has had or seen this issue and can help me?

share|improve this question
Try to reset the TCP/IP stack by running this command in an elevated command prompt : netsh int ip reset – shinjijai Jan 14 '14 at 18:36
I did that just after I posted this and it didn't work :( Thanks for the idea and response though! – Gerad Bottorff Jan 14 '14 at 18:41
I would boot up to a linux live cd and see if networking works in there. – shinjijai Jan 14 '14 at 18:51
It could be several different things causing this. Exactly as @shinjijai suggests - you need to troubleshoot and determine if the hardware is broken. Booting from a different OS (like a LiveCD, or using a fresh Windows install) is the best/easiest way to determine that. – Ƭᴇcʜιᴇ007 Jan 14 '14 at 19:05
Is this a windows vista machine? I've had problems in the past with certain updates disabling internet access (not network) for no apparent reason. Havn't heard of it on any other OS so if its not then my theory is shot =P – jak138 Jan 14 '14 at 22:15

Please check the event log ( on you computer for errors considering network services and post the errors here or google them. The event log should give you overall a good impression when looking for problems.

I could happen that your network services dont start as they should e.g DHCP service, netbios..

You could check the device manager as well to see if the networkcard itself shows any driver problems.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.