Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Photoshop file where I have a text layer with a very long paragraph. I would like to copy and paste the text to the editor where I write XHTML markup instead of rewriting it.

How can I do that? Ctrl+C and Ctrl+V doesn't work.

I have Photoshop CS4.

share|improve this question

migrated from stackoverflow.com Nov 13 '09 at 18:14

This question came from our site for professional and enthusiast programmers.

    
In Photoshop CS4 the shortcuts work fine! Try with the right click and choose copy! However, I think that this isn't a question related to programming!!! – BitDrink Nov 13 '09 at 18:14

Find the text layer in the layers list. Double-click layer icon (with the "T" on it). This will automatically select the text in the layer. Then you can use the copy and paste functionality (Control-C to copy).

**You can only do this if the text is not rendered into pixels yet. So as long has you haven't done this, it will work.

share|improve this answer

You should the Text tool (shortcut 'T') then photoshop will give you the hand to edit the text, making it possible to copy/cut/paste.

In case, it doesn't give you the hand, then it's probably not a text, and you won't be able to do that.

share|improve this answer

Make sure you have the clipboard turned on in Photoshop. Go to Edit > Preferences > General.

In the General box area make sure that "Export Clipboard" is checked.

share|improve this answer

First select the text layer in the layers palette. Then Ctrl-A to select all. Ctrl-C to copy.

share|improve this answer

A roundabout way to accomplish this is to save the file as a pdf, then copy the text from there. To be safe, select Preserve Photoshop Editing Capabilities" in the save options.

share|improve this answer

disable automatic selection of slices when using the first left control (black arrow)

share|improve this answer

I have found other reason by chance when I'm searching for the same problem : When you copy a text with special chars it doesn't work like this example in french "spécial" , otherwise it works if it's "special".

share|improve this answer

You must log in to answer this question.

protected by slhck Sep 24 '12 at 9:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?