Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've looked at many of the similar questions, but none seem to solve my issue. I'm running Ubuntu 13.04 Raring in a VM through VirtualBox and I'm trying to communicate with it from my OS X Mavericks side, but I can't ping the VM.

I've switched the interface to bridged over en0 (wifi) and my VM gets an ip, but it can't connect to the internet (pinging 8.8.8.8 fails). I turned 'cable connected' on. My local host ip is 10.0.0.10 and my VM's ip is 10.0.2.15, so they're on different subnets, and they can't ping each other.

Any ideas why this might be failing?

share|improve this question
    
If it is bridged, then the VM should get IP from the same range as your Mac OS X... is the Ubuntu VM set to get IP using DHCP? Or you have statically set the IP? –  Darius Jan 15 '14 at 16:08
    
It's set to automatic DHCP – should I try a static ip? –  Nick Sweet Jan 15 '14 at 16:24
    
I don't have enough karma to answer my own question, but here it is (feel free to copy/paste it and I'll accept it!): My settings weren't right in Ubuntu – I had to select the device MAC address of my eth0 interface in the network config and then restart the connection. –  Nick Sweet Jan 15 '14 at 16:31

1 Answer 1

up vote 1 down vote accepted

LOL

Try: Select the device MAC address of your eth0 interface in the network config and then restart the connection.

share|improve this answer
    
Thanks dude. Your setup is vaguely familiar - I'm doing similar with Ubuntu Linux 12.04 with Parallels 8.x and recently got X working between the host and VM - a trick - and some other things. Currently working on setting up a fixed IP. Got the public ssh keys setup. I'll keep an eye on your posts - maybe we can help each other out... –  Bill McCloskey Jan 15 '14 at 16:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.