Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Internet Explorer 11.0.9600.16476 (Update Versions 11.0.2). What happens is if I load IE by clicking a Desktop or Start Menu icon or a Windows shortcut key (assigned from Properties), it works ok. Also if I run iexplore.exe from cmd, that works. However, if I load iexplore.exe from AutoHotkey or a legacy command prompt called 4NT, then my laptop's touchpad two-finger scroll will not work in IE!

How is it possible that depending on what program iexplore.exe is launched by, the scrolling either works or doesn't work? I even tried making run-ie.vbs, which would in turn launch iexplore.exe. But if that vbs was ran from AutoHotkey, IE still couldn't scroll. I tried to fiddle around with Run as Administrator, but no luck so far.

What can be the reason for this strange behavior?

share|improve this question
    
1) What about other browsers or generally applications that support this type of scrolling, do they behave the same way when launched by AHK? 2) Maybe there's some other program/driver that takes low-level input, detecs two-finger gestures and converts them into a scroll (similarly to how AHK works). Try to find out if something like that exists, e.g. by disabling and continuously re-enabling autostart applications. –  MCL Jan 23 '14 at 11:09
    
Still no solution to this, it seems. Answers: 1) Other browsers do not suffer from this problem. For example Opera scrolls normally with touchpad two-finger scroll even if Opera was launched by AutoHotkey or in cmd.exe. 2) Couldn't find such program/driver so far. Instead I suspect that it is just a feature in iexplore.exe. Touchpad scroll works if you launch by clicking or pressing enter on .lnk or iexplore.exe. But touchpad scroll does not work if iexplore.exe or .lnk is launched by cmd.exe, AutoHotkey, a long chain of .vbs loading other scripts and eventually iexplor.exe... It's incredible! –  Jim Hoyle Feb 7 at 17:40
    
There's also some bug with trying to open IE by the normal Windows .lnk Properties "Shortcut key". That way the touchpad two-finger scroll does work, but otherwise it doesn't work correctly. If there's an IE window already open, sometimes the key combo opens the program, but usually it just deactivates current window but doesn't do anything else. –  Jim Hoyle Feb 7 at 17:49
    
Well, I made a workaround for this. Extremely stupid, but it seems to work, at least usually (AHK code, -- = actually line breaks):^!i:: ; IE bug workaround: if IE not loaded by "touch", then touchpad scroll won't work in IE -- Run, "C:\Program Files\Internet Explorer\AutoHotkey-Shortcut-Workaround\" -- WinWaitActive, AutoHotkey-Shortcut-Workaround ahk_class CabinetWClass,, 5 -- Send, {Down}{Enter} -- WinClose -- Return –  Jim Hoyle Mar 18 at 23:15

1 Answer 1

I'm not sure if this will be of any help or not, but here it goes. I had a similar problem before. The script I was using in auto hotkey was used to open things as well as simulate some keystrokes. The problem was that I had sent a down keystroke but did not follow it with an up key stroke. Thus, the computer had it that I was holding down Esc (for example). With this key effectively held own, the touch pad was disabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.