Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a Belkin wireless router, and just bought a new Dell computer with Windows 7 pre-installed. I can connect to the Internet and my home network just fine, but when I try to visit my router's configuration page at http://192.168.2.1, I get a "Connection was reset" error. Nothing I do will make the router's configuration page come up in my web browser.

More background information:

  • I could always get to the router's config page from my Windows XP machine. I never had any trouble prior to getting this Windows 7 computer.
  • I can ping 192.168.2.1 successfully from my Windows 7 computer.
  • My PC is connected to the router by a physical CAT5 cable, not via wireless.
  • Every device connected to my router, including the new computer, can get to the Internet with no problem.

Here are some things that did not solve the problem:

  • I tried turning off IPV6 in Windows.
  • I tried turning off my firewall and antivirus software
  • I tried using https instead of http
  • I tried disabling and then enabling the network connection in Windows
  • I tried reverting my network card driver back to an older version
  • I have tried both Firefox and Internet Explorer web browsers.

Has anyone experienced something like this before, and solved it?

Thanks a lot for your help!

share|improve this question
    
have you rebooted the router? have you tried resetting the firmware back to factory defaults? can other computers on your network access the router's config page? –  quack quixote Dec 2 '09 at 5:24
    
I have exactly the same problem. My netbook running XP can view the setup page at 192.168.2.1 fine, but my new windows7 desktop computer cannot. It can use the internet otherwise though, and ping 192.168.2.1. It simply cannot view it in a webbrowser. –  Nick Sep 28 '11 at 14:11

6 Answers 6

After some quick googling several people reported that the issue is created by the installed antivirus software blocking http access to local ip's.

Removal then re-installation of the antivirus software corrected the issue.

as a note simply disabling the av software did not correct the issue for those people removal was required

share|improve this answer

Does the same happen when you go to your network and right click the router to get to the administration page?

alt text

try saving your router's configuration settings on a machine that can access the administration page, then cold restart the router and reset the configuration.

share|improve this answer
    
John, yes -- I get the same error when right-clicking on the router and selecting "View device webpage". I will try cold-booting the router and let you know whether that affects anything. Thanks for taking the time to respond. –  user17940 Nov 13 '09 at 19:27
    
No problem, glad to help. I'd suggest restoring the settings manually if you can rather than just uploading the file, this way you may find the problem during reconfiguration. If you need to know your previous settings, the configuration file given to you when you save is usually just a plain text file, so you can open it and read the directives. –  John T Nov 13 '09 at 19:35

I just had a similar issue, and solved it as I realised I had used the guest WPA key on my windows7 computer (as it was freshly in my mind after giving it to someone else) but the origional WPA key was on my windows XP machine. The router will not accept connections to the configuration pages from people on the guest WPA key.

Make sure your windows7 machine is using the non-guest password to connect.

This may or may not be your problem, but it worked for me!

share|improve this answer

Can you still get to the page with another device? Also try looking in C:\windows\system32\drivers\etc\hosts. See if 192.168.2.1 links to anything unusual.

share|improve this answer
    
if he can get to the internet fine then this probably isn't the case, it's a great way to troubleshoot though if he couldn't. –  John T Nov 13 '09 at 19:26
    
You beat me by a few seconds, @Skaughty. This caught my eye too. he "could always get to the page", but it sounds like possibly he hasn't tried with that old machine since getting the new machine. –  JMD Nov 13 '09 at 19:29

It's unlikely that your config page is 192.168.1.254, but just to say that is what gets up my config page on my BT router.

share|improve this answer
1  
Guy - thanks, but it's 192.168.2.1 -- that's the default gateway in IPCONFIG, and it has always been the config page in the past. When I try any other address, such as 192.168.1.254, I get a time-out message. When I try 192.168.2.1, I get the "connection reset" message. –  user17940 Nov 14 '09 at 12:55

If you haven't found a solution for this yet, perhaps you could try out doing a clean boot. At the very least, this will rule out any rogue services or programs that are starting up, and it's worth a shot. Is the router's page accessible after running msconfig and disabling all services and startup items?

I found this thread on TechNet and though the problem isn't exactly the same, it's similar and it looks like the clean boot helped fix the problem.

share|improve this answer

protected by slhck Feb 11 '13 at 18:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?