Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ubuntu Gnome 13.10

What I can do:

  • ping hostnameX
    • Response: PING hostnameX.domain.local (10.0.0.1)
  • nslookup hostnameX
    • Response: Name: hostnameX.domain.local; Address: 10.0.0.1
    • Response coming from: Server: 127.0.1.1; Address: 127.0.1.1
  • nslookup hostnameX.domain.local
    • Response: Name: hostnameX.domain.local; Address: 10.0.0.1
    • Response coming from: Server: 127.0.1.1; Address: 127.0.1.1

What I CANNOT do:

  • ping hostnameX.domain.local
    • Response: ping: unknown host hostnameX.domain.local

This happens with all hostnames within the domain

This is my /etc/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
search domain.local

I already tried the same with dnsmasq disabled, without success...

UPDATE: I also tried some other distros (debian and opensuse), and they all have the same problem. So it looks to me as a general network problem, but what exactly...

Any clues?

share|improve this question
    
so when your nslookups succeed, do they indicate your that the nameserver responding to the query is the one running on 127.0.1.1? – Frank Thomas Jan 16 '14 at 12:42
    
@FrankThomas I added this to my question – intrixius Jan 16 '14 at 13:01
    
What does your domain.local zone look like? – NickW Jan 16 '14 at 15:20
    
@NickW do you mean on the dns server? I don't have access to the server unfortunately – intrixius Jan 16 '14 at 17:47
    
If 127.0.0.1 is serving domain.local, you should have access to it? – NickW Jan 16 '14 at 17:51
up vote 0 down vote accepted

While trying to join the windows domain with LikeWise, I found a note on this page in the troubleshooting section, which states to remove 'mdns4' entry from the 'hosts:' part in /etc/nsswitch.conf when trying to join an AD domain with a .local syntax. I did this and suddenly I could ping (and therefore also access) FQDNs within the .local domain ...

A second source is describing the same problem and sollution

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .