Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was going through this website for the installation of wireless driver for TP-LINK WN721N usb adapter. My kernal version is 3.8.0-19-generic. But the compact-wireless is available upto 3.6. While doing sudo make, I am getting below error.

./scripts/gen-compat-autoconf.sh /home/kunal/compat-wireless-3.6.8-1/.config /home/kunal/compat-wireless-3.6.8-1/config.mk > include/linux/compat_autoconf.h
make -C /lib/modules/3.8.0-19-generic/build M=/home/kunal/compat-wireless-3.6.8-1 modules
make[1]: Entering directory `/usr/src/linux-headers-3.8.0-19-generic'
  CC [M]  /home/kunal/compat-wireless-3.6.8-1/compat/main.o
  LD [M]  /home/kunal/compat-wireless-3.6.8-1/compat/compat.o
  CC [M]  /home/kunal/compat-wireless-3.6.8-1/drivers/bcma/main.o
In file included from /home/kunal/compat-wireless-3.6.8-1/include/linux/bcma/bcma.h:8:0,
                 from /home/kunal/compat-wireless-3.6.8-1/drivers/bcma/bcma_private.h:8,
                 from /home/kunal/compat-wireless-3.6.8-1/drivers/bcma/main.c:8:
/home/kunal/compat-wireless-3.6.8-1/include/linux/bcma/bcma_driver_pci.h:217:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘bcma_core_pci_init’
In file included from /home/kunal/compat-wireless-3.6.8-1/include/linux/bcma/bcma.h:10:0,
                 from /home/kunal/compat-wireless-3.6.8-1/drivers/bcma/bcma_private.h:8,
                 from /home/kunal/compat-wireless-3.6.8-1/drivers/bcma/main.c:8:
/home/kunal/compat-wireless-3.6.8-1/include/linux/bcma/bcma_driver_gmac_cmn.h:95:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘bcma_core_gmac_cmn_init’
In file included from /home/kunal/compat-wireless-3.6.8-1/drivers/bcma/main.c:8:0:
/home/kunal/compat-wireless-3.6.8-1/drivers/bcma/bcma_private.h:25:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘bcma_bus_register’
/home/kunal/compat-wireless-3.6.8-1/drivers/bcma/main.c:153:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘bcma_bus_register’
/home/kunal/compat-wireless-3.6.8-1/drivers/bcma/main.c:17:21: warning: ‘bcma_bus_next_num’ defined but not used [-Wunused-variable]
/home/kunal/compat-wireless-3.6.8-1/drivers/bcma/main.c:93:12: warning: ‘bcma_register_cores’ defined but not used [-Wunused-function]
make[3]: *** [/home/kunal/compat-wireless-3.6.8-1/drivers/bcma/main.o] Error 1
make[2]: *** [/home/kunal/compat-wireless-3.6.8-1/drivers/bcma] Error 2
make[1]: *** [_module_/home/kunal/compat-wireless-3.6.8-1] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.8.0-19-generic'
make: *** [modules] Error 2

Please suggest me what should I do.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.