Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I am used to setting up a new router being nearly a plug and play affair. This time however my new Rosewill L600N router refuses to give me access to the internet. I ran their auto-setup wizard to try and fix this and it got to a step where it "detected the type of internet connection I have" as 'Static IP'. It then prompts me to enter my IP, DNS server(s), and Gateway before continuing. FYI I have cable internet, not DSL. Why do I now have to know all this to connect?

And as a point of interest, why (in general) would a router ever need to know this information? I assumed that as long as the router knew which port the IP's outside of it's subnet were located (the modem port) it wouldn't need to know DNS and Gateway information. Does the modem itself not handle this?

share|improve this question
    
You shouldn't have a static ip address unless your ISP allocated you one. forums.legitreviews.com/about43580.html does seem similar to your issue tho –  Journeyman Geek Jan 17 at 3:10

1 Answer 1

up vote 2 down vote accepted

Yes, your router needs to know its public (WAN) IP address, default gateway address, and DNS server addresses. Typically this information is provided to your router via DHCP on most DOCSIS cable modem networks. It's likely that something went wrong when your router tried to detect its connection type, so it didn't (or thinks it didn't) get a response from a DHCP server.

One common cause of this with DOCSIS cable modems is that many cable modems "latch onto" the first MAC address they see out their LAN Ethernet port, and refuse to talk to any other MAC address until they are rebooted. [In some extreme cases, cable modems can be programmed by the ISP to only talk to the one MAC address you registered with the ISP, and you could end up having to call the ISP to get them to reprogram your cable modem.] This often causes problems when you upgrade from one router to another without fully power-cycling the modem at the appropriate time; it stays latched onto the old router's MAC address and won't talk to the new router. This also causes problems if you for some reason have a hub or switch between the cable modem and the router, and other devices hooked up to that hub/switch, allowing the cable modem to see MAC address of other devices than your router; your cable modem may latch onto one of those other devices MAC addresses, and ignore your router.

So, make sure you have a single Ethernet cable coming out of your cable modem's LAN port and directly into your router's WAN port. Now set your router for DHCP and reboot it. Make sure it is fully rebooted and fully sync'd to the cable network, then power-cycle your cable modem. Note that some cable modems have built-in battery backups, especially if they provide voice telephone services, so removing the power cord may not be enough; you may need to pull out the backup battery. After your cable modem is fully rebooted, see if your router got a DHCP lease from the network.

If this still doesn't work, it's probably time to troubleshoot your Ethernet cable. Or check the settings on your cable modem to see how it's configured. If your cable modem is actually a more sophisticated "cable gateway", it might have the ability to have its NAT and DHCP services turned off, which can make your network setup more complicated.

And there's still a rare chance that you have a cable modem that's been ISP-programmed for the MAC address of the previous router you were using. In which case you'll have to call your ISP.

It's theoretically possible to have cable modem service where there's no DHCP server on the network and you're expected to manually enter static IP address (and gateway and DNS server) information into your router, but unless you're in a backwaters town with a mom-and-pop cable operator, I doubt that's the case.

share|improve this answer
    
That is a magnificent answer. I'm tempted to mark this as accepted, but I'll hold off to try to encourage some other posts. Thanks for all the info though! –  user912447 Jan 17 at 3:35
    
@user912447 I'm more interested in knowing if it fixed your problem. –  Spiff Jan 17 at 4:27
    
Yeah it did fix the problem. I'm more embarrassed about not thinking to restart the modem though, once I saw the router telling me I had a static IP I believed it and didn't give it another thought. I guess I still thought that the modem would handle talking to the DNS and Gateway and changes would be pushed to it from the ISP, but I see that the router has to know where to send DNS requests and there isn't a standard message used in an ISP's network devices like "send these packets to the DNS". –  user912447 Jan 17 at 4:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.